Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed Windows 8 Enterprise EVAL on my Lenovo G560 and the screen brightness control stopped working. I tried installing both the video driver from Lenovo's website and the one from NVIDIA. I also reinstalled Energy management but it didn't help. I also updated the BIOS version and reinstalled the monitor driver but nothing changed. Thank you in advance, Lyubomir

share|improve this question
    
Have you tried compatibility with windows 7? –  poz2k4444 Sep 29 '12 at 18:23
    
Yes, I did but it didn't help. The brightness slider's value changes but the screen stays the same. –  Lyubomir Raykov Sep 29 '12 at 18:38
1  
Well, I haven't installed W8, but it could happen that the driver doesn't works with the SO, if lenovo doesn't support drivers for W8 and the compatibility doesn't work either, maybe it could be a good idea wait for the official release –  poz2k4444 Sep 29 '12 at 19:06
    
Is the brightness adjusted using a special keyboard combination? It may be a keyboard driver or software of some sort. –  dangowans Sep 30 '12 at 23:43

3 Answers 3

The problem has nothing to do with windows 8. As soon as you update your video driver your brightness control is gone. I've got windows 7 and couldn't find a solution on the web. Don't bother writing the Lenovo-Service.

Never ever ever I will ever buy a Lenovo again. Never.

share|improve this answer

On the Lenovo forum I was told to delete all occurrences of the key EnableBrightnessControl, using the Register Editor. The keys can be found at;

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class{4D36E968-E325-11CE-BFC1-08002BE10318}\0000]

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\Class{4D36E968-E325-11CE-BFC1-08002BE10318}\0000]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E968-E325-11CE-BFC1-08002BE10318}\0000]

This helped me to fix the issue.

share|improve this answer

I had the same problem on an Lenovo IdeaPad U430 Touch with Windows 8.1 installed. After some automatic Windows updates the brightness function keys (F11 and F12) did not work anymore and the screen brightness was set to very dark.

To solve the problem I downloaded and installed the Lenovo recommended Intel Chipset driver (in my case this was Intel Chipset Device Software, Version 9.4.0.1026, dated on August 05 2013). After a reboot the function keys worked again and the brightness control too.

You can find the packages for your laptop on http://support.lenovo.com/us/en/products?type=Laptops-and-netbooks&c=1 Choose your laptop model and "Chipset" for the software package.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.