Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I set up a Microsoft Exchange account on my iOS device to sync my Gmail contacts. But Microsoft Exchange is ignoring phone numbers that are labeled as 'iPhone' or 'main'.

For example, John Smith:

On Mac and Gmail:

John Smith
main: 123-334-1212
home: 123-330-1002
work: 123-330-8211
iPhone: 123-778-5556

On iOS device (via Exchange sync):

John Smith
home: 123-330-1002
work: 123-330-8211

I'd like to sync my contacts from my Mac to iCloud and Gmail, but you can't do both:

screenshot

Is there a solution to sync iOS and Gmail contacts without using Exchange? Thanks for any help!

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Great timing for this question. Google just announced that they have enabled CardDAV syncing for Google contacts. Visit the Google support forum page to enable it. Optionally, you can follow the copy-pasted instructions below:

  1. Open the Settings application on your device.
  2. Select Mail, Contacts, Calendars.
  3. Select Add Account...
  4. Select Other
  5. Select Add CardDAV Account
  6. Fill out your account information in the following fields:
    • Server: Enter "google.com"
    • User Name: Enter your full Google Account or Google Apps email address.
    • Password: Your Google Account or Google Apps password. (If you’ve enabled 2 Step verification, you’ll need to generate and enter an application specific password.)
    • Description: Enter a description of the account (e.g. Personal Contacts).
  7. Select Next at the top of your screen.
  8. Make sure that the "Contacts" option is turned to ON.
share|improve this answer
    
Thanks for your help! –  flackend Sep 30 '12 at 2:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.