Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using an SATA blu-ray drive (Lite-On IHOS104), connected via a USB adapter to my Windows 7 (32-bit) notebook.

The first time I plugged the adapter in, it worked perfectly. The drive appeared in Explorer, and my player software was able to play an encrypted Blu-Ray disc just fine.

After the first reboot, it never worked again. Now it shows up as "removable media" with a size of 0 bytes, irregardless of whether a disk is inserted or not. The drive does not show up under the green "eject USB device" icon in the taskbar. The adapter is powered using a separate power adapter.

I have tried:

  • disconnecting all other USB devices
  • testing with a DVD instead of a Blu-Ray disc
  • letting Windows search for updated drivers for the drive - there are none
  • using the same drive and adapter on another Win7 (but x64) computer. They work perfectly.
  • using other USB ports on the same notebook - tried them all.
  • using a different SATA/USB-adapter

What else can I do to diagnose this problem?

share|improve this question
Can you return it for an exchange? You may have an infant mortality. – Nicole Hamilton Sep 29 '12 at 19:48
The drive has been used for several years and works just fine when connected to the SATA port of a desktop PC. I have also tried it with another SATA/USB-Adapter, to no avail. – LTR Nov 4 '12 at 22:52

You must log in to answer this question.

Browse other questions tagged .