Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I download files using Ubuntu, and store them on my Vista partition, when I go to Vista, they all appear with the sharing icon on them. In the sharing dialog (right click > share > change permissions) it says the following (doesn't mean anything to me, but maybe it helps someone answering):

Everyone         Co-owner
Scott                Owner

In Ubuntu I can access all the files from the Windows partition, whether they're shared or not, so I guess it's not really important, just a bit annoying. If I try to stop sharing any files it takes several minutes for the dialog to say it's done, even though the icon disappears off the files pretty much instantly.

If I stop sharing any folders, the files inside the folders still have the icon.

So in short, I want to do one of two things:

  1. In Ubuntu, make it so any files saves to the Windows partition don't show up as "shared".
  2. In Vista, make unsharing files a lot simpler/quicker!

EDIT: should also add that I already disabled everything under Control Panel \ Network and Internet \ Network and Sharing Center

share|improve this question

3 Answers 3

up vote 1 down vote accepted

The reason it is probably showing up as shared because you have the containing folder / a higher folder shared and it is inheriting the setting.

Sharing is about sharing files over the network and not from another operating system on the same physical system.

If you go to the top level share, just unshare it and then new items you create will not be shared.

For example, if I have - c:\share as a shared folder, anything I create in it will automatically be shared unless I manually set it not to be. This is for both folders and files.

If I unshare c:\share, any new objects will not be shared by default.

share|improve this answer

Guess what you are looking for is (being) implemented in NTFS-3G Advanced driver. In particular, you may find this information useful: http://www.tuxera.com/community/ntfs-3g-advanced/ownership-and-permissions/

share|improve this answer

Just right-click the folder and select sharing, "in Vista" I was given an option to unshare. It worked to remove the sharing icon.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.