Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed Windows 7, and for some reason my Libraries don't open to My Documents, Music and so on.. I can access my files by typing into the explorers address bar, but clicking anything doesn't do anything, it just stays on the same screen. What's wrong?

Since this is occurring on a relatively new install, I currently have 259GB free out of 297GB on my HD. The My Documents folder only has about 500 mb of Data.

share|improve this question
    
What do you mean by doesn't do anything - What happens when you double click on it ? Does it stays on same screen ? Or the issue is about the content in those libraries ? –  Lamb Sep 29 '12 at 21:02
    
It stays on the same screen. Nothing opens. –  Link Sep 29 '12 at 21:06
    
What about folders, does clicking on folders act as expected ? –  Lamb Sep 29 '12 at 21:13
    
Well, if I click on a folder it takes me inside, but clicking on that library like homepage doesn't do anything. –  Link Sep 29 '12 at 21:19
    
Are you able to go inside library from the pane located at the Left side of explorer window ? –  Lamb Sep 29 '12 at 22:08

6 Answers 6

up vote 1 down vote accepted
+150

1

  1. Right-click and delete each library (Documents, Music, Pictures, Videos etc.)

  2. Right-click Libraries in Windows Explorer's left pane and click on Restore default libraries

  3. Test if the library locations work fine; if they do, re-add any custom library locations


2

Try running sfc /scannow from an elevated Command Prompt (Start / Type "cmd" (without quotes) / Right-click cmd.exe / Run as administrator).


3

  1. Create a new user account/profile

  2. See if libraries work fine; if they do, copy over your files from the old corrupted profile


4

  1. Make sure hidden files and folders are visible

  2. Navigate to %AppData%\Microsoft\Windows\Libraries in Windows Explorer and expand Libraries in the left pane

  3. Select the first library (for example, Documents) listed in the left pane

  4. Right-click and select Properties

  5. Go to the Security tab and see if your user name is listed at the top under Group or user names, and whether there is a check-mark against Allow Full control under Permissions below

  6. If not, click on Edit

  7. Click on Add

  8. In the object names input area, enter your user name and click Check Names, then click OK once found and validated

  9. Click on your user name in the top list of Group or user names

  10. Select the Allow Full control check-box under Permissions, then click on Apply

  11. Repeat steps 4-10 for each library

share|improve this answer
    
Thanks, but didn't work. –  Link Oct 1 '12 at 21:16
    
@Link: So in the left pane if you click on any library, what do you see in the right pane? –  Karan Oct 1 '12 at 21:19
    
Nothing changes. Just whatever screen I was intially on. –  Link Oct 1 '12 at 22:18
    
@Link: Ok, so solution #1 did not work. Can you try #2-4 in turn and report back with the results? –  Karan Oct 2 '12 at 2:13
    
Hmm, that worked!, but I've disabled libraries, they're not crucial. –  Link Oct 2 '12 at 2:16

Exactly the same thing happened to me, but I discovered that it was the user accounts settings that was corrupt. just go to user accounts and create a new user account, then give it full administrative rights. Delete your current user profile. It would ask if you would like to backup all your documents, pictures, etc. from the previous account into a folder on the new account, agree to that, then delete the corrupt account. Ensure everything is working perfectly in your new account, restart your PC, then rename the new user account back to the same name you used for the previous one. You can then copy and paste your backed up stuff to their various locations. Everything will be perfect and you won't need to tamper with ur registry files or stuff like that. All your programs installed will not be affected in anyway and everything will work perfectly.

share|improve this answer

Keep it simple:

Microsoft Fix It Center: Diagnose and repair Windows File and Folder Problems automatically

share|improve this answer
    
Didn't work. Thanks for the try though. –  Link Oct 2 '12 at 2:03

Try adding the folders manually to the libraries - click on a library, "Add folder to a library" and choose your music or documents or any other directory. Repeat for every library needed.

share|improve this answer

Perhaps your library settings aren't generating properly? Others have suggested resetting to defaults through the Windows GUI, but it could be that something is preventing that step from completing successfully.

Trying resetting to default again, and then check the Event Manager snap-in. Look under System or Applications and see if any errors that may be related are shown.

If that doesn't shed any light, try going to this path in Explorer:

%USERPROFILE%\AppData\Roaming\Microsoft\Windows\Libraries

Your libraries will be listed in this folder. Double-clicking on them should open the library. If you right-click, though, you can open the file in a text editor (I was able to open them in Notepad++ using the Edit with Notepad++... context menu entry it can install with), and you'll notice that they're simply XML files. You should, at the least, be able to check that the XML syntax is correct by eyeballing it. They should look similar to the example shown here: http://msdn.microsoft.com/en-us/library/windows/desktop/dd798389(v=vs.85).aspx#libraryms_example

If Windows is generating corrupted XML files (assuming your attempts to reset to default as others have suggested didn't fix it), I would suppose that you have bad sectors on your hard drive and those files are getting partially (or wholly) stored on them. Try running scandisk and seeing if it detects anything. If it does, it should mark those sectors as bad, and cause Windows to try and recover those files elsewhere, or at least the next time you regenerate them they'll be stored elsewhere on the disk.

share|improve this answer
    
Well, went to the path, but that didn't help either. I'll try scandisk now then. –  Link Oct 1 '12 at 22:27
    
@Link What didn't help? Double-clicking them there didn't work? Makes sense. Did you try viewing the files in a text editor and seeing if they looked corrupt? Regardless, scandisk should help if it indeed is an issue. –  Ben Richards Oct 1 '12 at 23:01
    
Hmm, ran scandisk,, nothing came up. –  Link Oct 2 '12 at 0:44

Sounds almost like your system is hanging do to long load times, this could be caused by having to many files in the folders/on the drive for your hardware to process quickly enough to open the folder.

Could you state your system specs and if possible space left on your disk and total space?

share|improve this answer
    
reflected question for your question. –  Link Sep 30 '12 at 1:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.