Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

As the title states, I'm trying to connect my Alfa (AWUS036H) to backtrack5 r3. I've already installed the drivers on my host (windows 7). When I go into VMPlayer and try to disconnect it from the host. I get the error "Connection for my usb device 'Realtek RTL8187_Wireless_Lan_Adapter' was unsuccessful" the device is currently in use. I then tried to disable the device from the host. That didn't work either. How can I get my AWUS036H to connect to backtrack 5 r3?

Even after removing the device, I still get a device busy error.

share|improve this question
add comment

migrated from security.stackexchange.com Sep 30 '12 at 1:07

This question came from our site for Information security professionals.

4 Answers

up vote 3 down vote accepted

If you have USB 3.0 it's not compatible with backtrack. Uninstall the Intel USB 3.0 host program from the control panel, then open device manager and for all usb hubs (unless you know which usb port your wifi card is connected to) right click on each and select 'Update Driver software', then click the 'Browse My computer' option, then 'let me pick from a list', and lastly click 'Generic USB'. It will update the USB driver to USB 2.0 making it compatible with Backtrack 5. I tested this on Backtrack 5 r3 under VMware version 5.0.1 build-894247 on Windows 7 Home Premium, 64-bit 6.1.7601, Service Pack 1. Hope you can understand my crappy instructions!

share|improve this answer
add comment

I believe you can setup a rule or filter in VMware to have a device automatically connect to the Guest OS.

You don't actually need to setup windows drivers in the Host OS. When it connects successfully to the guest OS, windows will read it as "VMware USB device".

Try a different usb port, and reconnect while the virtual machine has mouse focus.

share|improve this answer
add comment

Do you have an Asus G75 laptop by any chance?

I'm having this issue too, and I've seen it reported at the following posts:

Looks to be like VMWare doesn't support USB 3 correctly and there is no way to downgrade a port to USB 2? It sucks because I have this adapter too and want to use it in a Backtrack VM rather than allowing the non-VM host OS to use it.

share|improve this answer
    
No, It's an Asus K55R. –  Digital Fire Nov 14 '12 at 15:21
add comment

I have this exact same setup but I am using VirtualBox instead of VMWare Player. I am able to get the AWUS036H to work in a BT VM without issue in VirtualBox. I suggest installing VirtualBox to see if it resolves the issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.