Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 2 computers (laptop, tablet) set up in the same Homegroup.

For file exchange, one has a folder mapped with read/write permissions for the homegroup (on laptop).

When I open the networked folder localy (\\mylaptop\mysharedfolder) everything works fine: I see verything I want to.

When I go to the 2nd pc (tablet) and open the same location on the laptop, I see only some of the folders and files. The selection seems to be random. When I modify the files/folders that are visible, it updates on the tablet as well, if I do anything to the invisible ones, nothing happens. They stay invisible/inaccessible.

Removing the visible ones did not make any of the invisible ones visible. Tried switching the firewall of on laptop, nothing.

Also, I tried sharing a folder on the tablet, that one is not visible on the laptop at all - it is not even visible on the tablet (\\mytablet\mysharedfolder).

So the general setup works: hopegroup, password correct, ..., but some folders/files are missing, or it seems like the tablet has a problem. Any ideas on/solutions for this problem?

share|improve this question
    
If it's just for files, why don't you try with dropbox? –  poz2k4444 Sep 30 '12 at 18:12
    
Because the size of the files is in the order of GBs, and it is on a local network with 100MBit LAN/WiFi with 300MBit, whereas.. DropBox would be rather slower (internet up/down again)?! Plus, with DropBox I would have to care about security as well. –  Andreas Reiff Sep 30 '12 at 19:26

2 Answers 2

Your files may have individually-set permissions that differ from each other. To correct this:

  1. On the host (sharing) computer, right-click on the top-level folder and select Properties
  2. In the Properties dialog, click on the Security tab
  3. Ensure that the permissions for this folder are correct (use the Edit... button to change them if not)
  4. Click on the Advanced button
  5. On the Permissions tab (should be visible already), click the Change Permissions... button
  6. At the bottom of the dialog, check the box labeled Replace all child object permissions with inheritable permissions from this object
  7. Click Apply and confirm that you want to apply the permissions for this folder to all children

This fixed my problem; hopefully it fixes yours as well.

share|improve this answer
    
Thanks for bringing this back to my mind. Actually, I will just post what I have found out (at least in my particular case). –  Andreas Reiff Sep 8 '13 at 19:13
up vote 0 down vote accepted

In my particular case, the problem was.. public and private document folders in Windows.

Actually, both are locally mapped into the same view - which I did not notice - but I only shared the public video and music folders. Per default, Windows copied new files into the private (user) folders though.

Once I found this out, I simply always use the public folders, even locally, and made respective shortcuts that I use now.

So if you have a similar problem with and documents folder behaving strangely with different users or from the home network, please make sure that you put the files you want shared into the public version of those folders.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.