Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was given this second hand wireless router a while back. It generally works fine, but sometimes loses all its settings. It gets turned off at night, along with the PC and cable modem, so I'm guessing that the non-volatile memory is volatile after all, but it doesn't happen every time.

To save me opening this thing up, can someone tell me if it has a battery I can replace or if it is just likely to be faulty.

It's mainly a pain as it loses the wireless settings. I don't want it going back to unencrypted.

share|improve this question
Have you tried resetting to using the pinhole button in the back? I think that clears NVRAM. That router could have had DD-WRT installed on it and maybe the previous owner restored the factory firmware w/out clearing out NVRAM. – hyperslug Sep 28 '09 at 21:38
Since installing the latest Firmware the problem has not re-occured. – Steve Oct 6 '09 at 20:56
I have this device with dd-wrt. It has been working great, but now loses it's settings with any power loss. I'm totally bummed as dd-wrt has worked great. Does anyone have any suggestions for a fix or a replacement dd-wrt capable device? – Chasler Dec 27 '09 at 7:30
up vote 2 down vote accepted

There is no battery in this device. Likely the NVRAM isn't working correctly or it was relying on a capacitor which doesn't last all night. Personally I would first check for firmware upgrades on the Linksys by Cisco site (silly name) incase this firmware isn't correctly using NVRAM.

share|improve this answer

IMO you can't do anything to fix this problem other than asking the manufacturer for a maintenance or buy another router.
A workaround of this problem is to export your router settings, and import them once they're lost.

share|improve this answer
I think the router is too old to be worth fixing. I updated the firmware last night and will see if that helps. I have been importing a settings file when it lost them – Steve Sep 29 '09 at 7:51

no battery.

try updating to the latest firmware (or DD-WRT or Tomato, whichever you prefer)

if that doesn't fix it, consider it toast.

share|improve this answer

I think you'll have to live with it losing setting it left off overnight, a firmware update is a good thing to try, as it's free.

Assuming that doesn't help, you're choices are either replace it, or leave it turned on overnight. I don't think it'll waste that much electricity.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .