Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I press Ctrl+Alt+Del to lock my Windows 7 computer, it takes a long time before the lock screen is displayed.

Why would it be so slow to load the lock screen and how can I fix it?

share|improve this question

closed as not a real question by Xavierjazz, techie007, Dave M, ChrisF, Indrek Sep 30 '12 at 20:22

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
What are you trying to achieve? –  Xavierjazz Sep 30 '12 at 19:37
    
I think it's written in my post ;) –  SEARAS Sep 30 '12 at 19:37
2  
Are you talking about a specific computer, or do you think it's slow in general (on every Windows 7 machine)? Mine is fast, and so has been every computer I can think of that isn't busy doing something. Perhaps you have a busy (background) process? What have you tried already to diagnose? –  techie007 Sep 30 '12 at 19:40
1  
> I think it's written in my post No, actually it’s not. What exactly is “loading”, Task Manager, the Windows logon prompt? –  Synetech Sep 30 '12 at 19:46
2  
I have seen it the machine is ground to a halt, so you press ctrl-alt-del to get up task-manager to kill off the offending process. But it takes an age. I thing it used to run an higher priority, so you could use it to kill stuff. –  richard Sep 30 '12 at 19:53
show 20 more comments

2 Answers

up vote 2 down vote accepted

The same problem exists in vista and xp, and still in 8 as well. The problem as well as the solution is in the hardware. Usually the hardware that comes in a computer is bare minimum to run the software, I noticed the same problem in one of my own computers but after adding a gig of ram to the computer it became instantaneous.

EDIT: So simply put, add a extra gig of ram to your computer and it should solve your problem.

share|improve this answer
add comment

Try and use other shortcuts to do the same functions as some of the options on the Ctrl-Alt-Delete screen.

  • Ctrl-Alt-Escape Brings up the Windows Task Manager
  • WindowsKey-L Locks the computer
share|improve this answer
1  
Ctrl-Alt-Del doesn't bring up the UAC prompt. –  techie007 Sep 30 '12 at 19:48
    
Your correct, Ctrl-Alt-Delete doesn't fade the screen so removed that part of the answer. –  Brian Sep 30 '12 at 19:55
    
Ctrl+Shift+Escape brings task manager, not Ctrl+Alt+Escape –  SEARAS Nov 2 '12 at 16:52
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.