Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Today I turned an old PC into some kind of a "server", which means that I want to leave it running 24/7. I don't need any display as I will use the machine via ssh so when everything was set up I removed my monitor. After a hour I checked my graphic card's cooling system and it was still hot.

My graphic card is GeForce 8600 (with DVI connector), OS is Debian Linux.

Does GPU render anything when there is no monitor plugged in?

What is the best solution in this situation (standalone server) if GPU is active and I don't want it to waste power?

share|improve this question
4  
Why don't you take out the GPU? –  ekaj Sep 30 '12 at 20:09
1  
My motherboard (ASUS P5K) will halt when no video card is detected. –  Mixer Sep 30 '12 at 20:20
1  
you'll likely find that in the bios there's a settting "Halt on errors" set to "all errors" - set that to "no errors" and you should be able to boot it just fine without a gfx card. That's what i use, and then just use a serial cable + minicom to get the console if i need it. –  Sirex Sep 30 '12 at 20:29
    
@Sirex This will not help. There are some BIOS versions that could load without video and some that refuse. We are speaking about desktop motherboard that is not designed to work headless –  Serge Sep 30 '12 at 20:32
    
really ? i've never seen one that won't. –  Sirex Oct 1 '12 at 18:29

5 Answers 5

up vote 2 down vote accepted

The GPU will remain active and is likely rendering the console or (more likely) the X display. If a compositing window manager such as Compiz is being used, the GPU will be in 3D mode, which may be why it is running hot.

Make sure the system is not set to start the X server, which is the platform on which most graphical applications run. Try booting the computer into runlevel 3, so that X does not start; see this Wikipedia article for more details.

If this doesn't work, you'll need to use a low-powered video card, such as a GeForce GT 610.

Edit: You said that no GUI is running. Disable kernel mode setting and set the system resolution to VGA by using the kernel boot parameters nomodeset vga=0x101, so that the kernel isn't causing the GPU to run at a higher power level than necessary by using a higher-than-necessary console resolution. However, given how old the 8600 GT is, it may not run efficiently even in text mode; if this is the case, you'll need to replace the video card.

share|improve this answer
    
I have no GUI environment installed (so no X server), just ordinary console. –  Mixer Sep 30 '12 at 20:35
    
@Mixer: See edit. Tweaking the kernel video parameters at boot time may solve the problem. –  DragonLord Sep 30 '12 at 20:49

Set the power options to 'turn off the monitor' after a certain amount of time. That's about all you can do short of removing the graphics subsystem (for the console). As long as there's a graphics adapter in there, it's going to consume some power just to stay active, and will probably be 'hot' even at idle.

It's going to be up to your specific motherboard's BIOS whether you can fully remove the graphics adapter and still boot. This is NOT a usual option for desktop-style motherboards.

More info

You could perhaps try and get a less feature-rich video adapter to use, but there's no telling if it would actually be any more efficient or not, unless tested.

share|improve this answer

No matter if a monitor is connected or not your computer will still render the image that would appear on screen unless the software is specifically designed not to.

share|improve this answer

Find some cheap display adapter to make it booting. If you are going to run your server 24x365 you will save some money in the first year

share|improve this answer

Boot the 'server' in text mode only - having no GUI session of any kind would prevent GPU drivers from being loaded and from initalizing the power-hungry 3D engine.

Alternatively, and entirely contradictory, boot it in GUI mode regardless with some fake monitor configuration, and the official nvidia driver - the driver might initialize the gpu and get it down to powersave.

Try it both ways with a kill-a-watt or a similar power meter.

share|improve this answer
1  
I forgot to mention that I run my Debian in text mode, I have no GUI installed at all and still my video card is hot. –  Mixer Sep 30 '12 at 20:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.