Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have my iTunes library set to sort by music by Artist, then album enter image description here. For most of my albums this will also sort the albums in the correct track listing order (using the track number tag).

Except for one album:

enter image description here

As you can see, "The Boy Who Knew Too Much" seems to sort erratically. Why is this happening and how can I fix it?

share|improve this question
    
Moreover, Grace Kelly (Acoustic) appears first in Life In Cartoon Motion album, though its track number is 12. –  mouviciel Sep 29 '09 at 8:24
add comment

4 Answers

I'm not seeing something like this so something is really strange. Maybe it's because they are formatted as "x out of y"? What happens if you just change to just "x" instead?

share|improve this answer
    
Have the track listings both ways, and it sorts fine for all of them. There does not seen to be a clear difference between this and other albums –  David Pearce Sep 28 '09 at 21:02
1  
Very weird indeed. –  alex Sep 28 '09 at 21:11
add comment

Make sure all the tags that should match actually do match for all the files in the album (Artist, Album Artist, Year, etc...). Select the whole album then Get Info to set tags for multiple tracks.

I would start by setting the Album Artist to Mika (for the example you've given, obviously) if it isn't already.

I notice in Life In Cartoon Motion, Grace Kelly (Acoustic) is set as 12 of 14 and Over My Shoulder [Hidden Track] is set as 12. Things like this could be causing your problem.

share|improve this answer
add comment

Had this same problem with the latest version (9.1.1.12) - was that the Disc n of n was not filled in for all tracks.

Selected all tracks, Get Info and then entered Disc 1 of 1 and saved, fixed the problem

share|improve this answer
add comment

Another possible solution to this problem is to check whether there is anything entered into the 'Album Artist' field on the tracks that appear to not be sorting properly in an album. This can mess with your sorting, and and you might not have "Album Artist' selected for viewing in your iTunes library view. So the simplest way to check this is the case is to:

  1. select your album
  2. click Get Info
  3. click the tick box next to album artist
  4. click OK
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.