Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I followed that tutorial for Xen 4.2 on CentOs 6.3. http://www.howtoforge.com/virtualization-with-xen-on-centos-6.3-x86_64-paravirtualization-and-hardware-virtualization

When building a new libvirt package with rpmbuild -bb libvirt.spec

I get that error :

 CC     libvirt_driver_libxl_la-libxl_conf.lo
In file included from libxl/libxl_conf.c:43:
libxl/libxl_conf.h:61: error: field 'ctx' has incomplete type
libxl/libxl_conf.h:80: error: field 'ctx' has incomplete type
libxl/libxl_conf.h:81: error: expected specifier-qualifier-list before 'libxl_waiter'
libxl/libxl_conf.c: In function 'libxlMakeDomCreateInfo':
libxl/libxl_conf.c:365: warning: implicit declaration of function 'libxl_init_create_info' [-Wimplicit-function-declaration]
libxl/libxl_conf.c:365: warning: nested extern declaration of 'libxl_init_create_info' [-Wnested-externs]
libxl/libxl_conf.c:367: error: 'libxl_domain_create_info' has no member named 'hvm'
libxl/libxl_conf.c:383: warning: implicit declaration of function 'libxl_domain_create_info_destroy' [-Wimplicit-function-declaration]
libxl/libxl_conf.c:383: warning: nested extern declaration of 'libxl_domain_create_info_destroy' [-Wnested-externs]
libxl/libxl_conf.c: In function 'libxlMakeDomBuildInfo':
libxl/libxl_conf.c:406: warning: implicit declaration of function 'libxl_init_build_info' [-Wimplicit-function-declaration]
libxl/libxl_conf.c:406: warning: nested extern declaration of 'libxl_init_build_info' [-Wnested-externs]
libxl/libxl_conf.c:408: error: 'libxl_domain_build_info' has no member named 'hvm'
[...]

Do you know what I need to install or change to pass that step?

share|improve this question
    
Did you fix/get this to work? I'm having the same issue.. –  Daniel Oct 17 '12 at 12:14
    
Unfortunately no... but I made by pci passthrough working with Kvm if this can help you : alapointe.degraeve.us/post/33244525132/… –  Frederic Oct 17 '12 at 15:09

1 Answer 1

up vote 2 down vote accepted

As discussed here: https://www.crc.id.au/2012/09/20/xen-4-2-0-packages-pushed-to-the-repos/ the current version of libvirt is not compatible with xen 4.2. You may continue with KVM or use Xen 4.2 without libvirt.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.