Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a new Ubuntu install where I am not able to connect to localhost or 127.0.0.1 or using my computer name.

telnet localhost [tried all/no port numbers]

returns

telnet: Unable to connect to remote host: Connection refused

Is there any configuration I need to do to make this work? Would it be disabled by default??

share|improve this question

migrated from stackoverflow.com Oct 1 '12 at 3:52

This question came from our site for professional and enthusiast programmers.

2 Answers 2

Are you sure telnetd is running?

sudo apt-get install telnetd
share|improve this answer
    
telnet is working. –  user1076371 Oct 1 '12 at 3:37
    
just wander what @pb2q changed in my post –  Roman Newaza Oct 1 '12 at 3:39
    
@RomanNewaza you can click the edited ... ago to see the edit history of any post: I simply changed a typo: you had telned –  pb2q Oct 1 '12 at 3:40
    
oh, good info! thanks! –  Roman Newaza Oct 1 '12 at 3:41
    
@user1076371: "telnet is working"?!? What about the "connection refused"?????? Please follow Roman Newaza's advice (which is good advice!), and please look at my link (of which "install telnetd" is a part). –  paulsm4 Oct 1 '12 at 3:51

Q: Is "telnet" enabled?

If it isn't, or if your iptables firewall is configured to block telnet, then you'll get exactly this error :) Try "apt-get install telnetd".

And don't try to "telnet" except on your local LAN - it's NOT secure!!!! Always use SSH instead.

This link might help:

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.