Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using FreeBsd 9 and I need to use Vi. My problem related with the changing mode (command to insert or insert to command) in VI. I know that I need to use ESC key to change mode. But in Insert mode (while typing some codes) when I press ESC key it prompts ' ^[ ' char. It doesn't let me switch command mode insert to command.

Do you know any fix or settings for this ?

share|improve this question

migrated from stackoverflow.com Oct 1 '12 at 4:03

This question came from our site for professional and enthusiast programmers.

    
Perhaps you have some mappings interfering? Do you see any with ":map <Esc>" and ":map! <Esc>"? – Ben Sep 28 '13 at 20:07

I may not understand what you are asking, but, have you tried pressing colon instead of escape?

share|improve this answer
    
Yes i tried every combination. I just improve my question. Thanks you. – zapoo Oct 1 '12 at 14:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .