Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two IBM/Lenovo Thinkpads, both running Gentoo Linux.

One is a T40 with an Intel 2915 ABG wireless adapter, and the other is a T500 with an Intel 5100 AGN.

When both systems are running and connected to my WPA2 wireless network, either one or the other will have a working network connection, but never both. The wireless driver will indicate that the connection is active, but I won't be able to ping the router's internal interface and domain lookups will fail. I have tried all manner of resets. The only thing that gets networking working again is to turn one of the Thinkpads off.

The wireless router -- a Sphairon IAD 3232 provided by my Internet provider -- seems to be able to handle multiple connections from other devices just fine. This problem only appears when both Thinkpads are on the network. The Sphairon supports 802.11 N, and the T500 is the first device that I have which supports this. I wonder if that is a possible factor in this problem. (My roommate has a MacBook, but I don't know if it has an N adapter in it. He has yet to notice any problems.)

It turns out that at least one other person has had similar issues:

http://www.wirelessforums.org/alt-internet-wireless/re-two-ibm-lenovo-thinkpads-over-wireless-network-16583.html

http://compgroups.net/comp.sys.laptops.thinkpad/end-of-two-ibm-lenovo-thinkpads-ove/82535

He claims to have "solved" it by switching to WEP encryption, which is not an acceptable solution.

What might be causing this, and how can I go about troubleshooting and resolving it?

share|improve this question
    
At home and at work, I have and have had many various models of Thinkpads connected to the same router and - as time passed - with WEP and then WPA2. Have you tried other, older devices such as the T40 on the network at the same time as with relatively newer devices such as the T500? –  FredrikD Oct 2 '12 at 18:04
    
@FredrikD: These are both the only ones I have to test with, and the only ones giving me problems. I have ordered a different router to see if that will help matters. –  Stephen Bosch Oct 6 '12 at 7:32
    
@FredrikD Oh, and it's worth pointing out that the 2915ABG in the T40 is not the WLAN device it shipped with; that was an upgrade I did a couple of years ago. Up until now it hasn't given me any trouble, and so I doubt that it is the cause of this. –  Stephen Bosch Oct 6 '12 at 7:33
    
Have you checked that there is no "peer to peer" connection active on the Thinkpads? I think that this was a feature on older version of TP:s and it could explain why they interfere. –  FredrikD Oct 7 '12 at 13:42
    
@FredrikD As both of these Thinkpads are running Linux, that would be unlikely. I don't think a peer to peer connection could be set up anywhere other than in software. –  Stephen Bosch Oct 7 '12 at 19:41

1 Answer 1

up vote 0 down vote accepted

The problem was ultimately resolved by a change in wireless routers: when I switched to a FRITZ!Box 7360, the problem disappeared completely.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.