Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a way to tell xrandr "this space intentionally left blank"?

I have a laptop that drives its internal display at 1920x1080, but the external monitor I'm using, due to its different aspect ratio, doesn't have that mode. It runs at 1920x1200.

So, the basic setup:

xrandr \
--output LVDS-1 --mode 1920x1080 \
--output DP-1 --mode 1920x1200 --same-as LVDS-1

[not to scale:]
┌─────────────────┬─────────────────┐
│                 │                 │
│  (laptop)       │  (external)     │
│  (LVDS-1)       │  (DP-1)         │
│                 │                 │
│                 │                 │
└─────────────────┤                 │
   (blank...)     │                 │
                  └─────────────────┘

How can I specify that the 1920x120-sized region below LVDS-1 should be displayed as a black bar that can't be accessed by mouse on DP-1?

I tried just coping with --panning 1920x1200+0+0/1920x1080+0+0/0/0/0/120, but I found the screen movement to be very annoying.

Update:

I found a workaround. (Update 2: changed it to an answer, per suggestion -- workaround doesn't answer the underlying question of leaving space blank.)

share|improve this question
    
Please consider posting the workaround as answer. You don't have to accept it, and can still point out the flaws, but it's more discoverable that way. –  Daniel Beck Oct 2 '12 at 8:10
    
Done. Thanks for the suggestion. –  benizi Oct 2 '12 at 8:37

1 Answer 1

I found a workaround in a discussion about aspect ratios under Compiz (a variant on option #2):

xrandr --fb 1920x1080 \
--output LVDS-1 --mode 1920x1080 \
--output DP-1 --mode 1920x1200 --scale 1x.9

This makes the external monitor scale the image. I'm not sure the --fb 1920x1080 (which specifies the size of the virtual screen) is strictly necessary here. Possibly --pos 0x0 would supplant it.

Workaround is still pretty unsatisfying -- it only happens to work out because it's a nice, easy multiple -- it would be nice to have a more general solution.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.