Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just tried to install Taglocity for use with Outlook 2007 (12.0.6423.1000) SP2 MSO (12.0.6425.1000).

After reading the FAQ, I went to Tools ⇨ Trust-Center ⇨ Add-ins. I found Taglocity 2.0 there under Inactive Application Add-ins.

In order to activate the add-in, I selected Manage COM Add-ins, then clicked the Go button. Now, Taglocity 2.0 was in the available add-ins list, but was unchecked. By selecting it, the Load Behavior message displayed the following error:

Not loaded. A runtime error occurred during loading of COM add-in.

Does anybody have any idea why this might be happening or how to fix it?

In addition, does anybody know if is there is way to see which exact error has occurred during loading?

I already tried contacting their support via email, but I think I can get a faster response here.

Update 1:

I tried using Taglocity BETA instead, but that too does not work; Outlook ignores it altogether. I’ve run Taglocity Diagnostics, though and got the following problem:

Taglocity ProgID is correctly registered.

Taglocity could not be instantiated. (Creating an instance of the COM component with CLSID {30C4BAA0-7730-4B68-8B9A-A36EDBFD67EB} from the IClassFactory failed due to the following error: 80070057.)

Running the diagnostics for Taglocity 2 doesn’t show anything unsual.

Update 2:

One important detail that I’ve missed (and turned out to be the cause of the problem) is that I have a beta version of the .NET Framework 4.0 installed on my machine.

share|improve this question

Taglocity support normally replies within a day (in my experience).

Taglocity does has a logger, as part of its diagnostics:

(1) Shutdown Outlook (like really shut it down, check the task manager to make sure)

(2) Go to in Windows Explorer: C:\Users\\AppData\Roaming\Terazen Technology\Taglocity 3.0

(3) Rename a file called Taglocity.dll.offlog4net to be called Taglocity.dll.log4net

(4) Start Outlook and now try to activate the add-in again, i.e. do what you did above.

The log file Taglocity-Diagnostics.txt will contain the startup sequence and what went wrong.

In my experience it is usually things like:

(1) A borked .NET install, i.e. do a repair on the latest .NET runtime

(2) Some other add-in being incompatible, especially older ones that try to run with .NET 1.1 only and run first.

(3) Local Exchange/Outlook policy that disables add-ins (i.e. your exchange admin can do this and not tell you).

(4) Vista/Win7 getting confused with apps registered and run at admin / not at admin

Hope this helps

share|improve this answer
+1 Thanks for your answer. That was a very relevant tip. As you said, Taglocity support answered too, and they nailed the problem. I'll post an answer with their solution. – jpbochi Sep 29 '09 at 13:25
up vote 0 down vote accepted

This is the solution that Taglocity support provided.

In order to avoid any problems with .NET Framework 4.0, I put a config file named outlook.exe.config in the folder were Office is installed (C:\Program Files\Microsoft Office\Office12). The content of the config file is as following.

<?xml version="1.0" encoding="utf-8" ?>
<startup><supportedRuntime version="v2.0.50727"/></startup> 

This completely solved the problem with Taglocity 2.0.

Taglocity 3.0, though, kept the same behavior. No trace of it is shown in Outlook. I'll keep the question unanswered for a while to see if anyone has another ideas.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.