Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I currently have the retina MacBook Pro running OS X lion and want to force the wireless card to only connect only to 5GHz networks.

Both the 2.4GHz and 5GHz have the same SSID so I can not pick which band the wireless card connects to.

Notes: I live in a college dorm, so renaming networks is not an option. They do not have 2 different names in the preferred networks list. The network also needs a 802.1X profile to connect to the network. (I can modify it if needed) The security is TTLS with PAP.

share|improve this question
Awww, I came here expecting to find answers of how to overclock my MBP :( – Darth Android Oct 1 '12 at 19:42
Hrm, windows allows you to choose the band I think. Is there a way to change the roaming aggressiveness to very low or zero, or force connect to 1 mac address? – cloneman Oct 2 '12 at 7:50
That's windows. Is there a way to force connections based on MAC addresses in on OS X Lion? (Also note I have to use a 802.1X configuration to connect because this is OS X Lion.) – Sid Oct 2 '12 at 16:47

2 Answers 2

Apple does not provide an API for forcing the band selection.

If you're seeing a bug or suboptimal behavior out of the band selection algorithm, it might be interesting to see the output from the "Wi-Fi" section of a full System Profiler report, because that'll show your current connection as well as the signal strength and other parameters of the other APs around you.

Well, on second thought, I suppose that only scratches the surface, because that wouldn't show how busy those other channels are, and it wouldn't show the effects of non-Wi-Fi interferers.

share|improve this answer
It isn't a bug in a selection, there are multiple APs broadcasting both at 2.4 GHz and 5 GHz. The 2.4 GHz channels are extremely crowded. If I am in a certain part of the room, the card connects to the 5GHz but when I move it back to my desk it reconnects to a 2.4 GHz channel. – Sid Oct 1 '12 at 20:07

Did you try to manually set the wifi channel number? If you want just to change from one frequency band to another then you can try the partial solution which I provide below. This worked for me (OSX Mavericks). Basically, if the frequency bands have different channel numbers then setting the channel number of the desired frequency will enable it. You can change the channel number using the airport, but first check if 2.4 and 5 GHz have different channel numbers:

  1. Open Wireless (it is located in /System/Library/CoreServices/Applications).
  2. In the application menu select Window->Utilities (or press cmd+2).Utilities window should appear.
  3. Select WiFi Scan from Utilities window and press Scan Now button. This will show you all available networks, info about them and your active connection.
  4. Now, verify that BSSIDs of 2.4 and 5 Ghz with the same network name are on different channel numbers. If so, then most likely you can change the band by setting the channel number of the desired frequency band.
  5. For this, open the and type: sudo /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport --channel=num where num is the channel number to set. This command will only work under administrator account (so make sure that you are log as an Administrator i.e. su YourAdministratorAccount)
  6. You can check your active connection by re-scanning with Wireless Diagnostics or Alt+Click on the WiFi icon on OSX the menu bar.

That's it! P.S. If you can not set the channel try to turn off the wifi device before using the airport command. As suggested by 8bittree, the instructions were included here from this post.

share|improve this answer
You should include the relevant information from that link in this answer, especially since that question was closed as off topic and thus has a good chance of being deleted. As it is, this seems like it would fit better as a comment. On a side note, you can use the share button under an answer to link directly to it. – 8bittree Aug 26 at 15:11

protected by bwDraco Aug 26 at 13:55

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.