Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently assembled a PC with two different brands of memory with identical timings (9-9-9-24) and speed (1333 MHz). My motherboard, an Asus P8Z68-V, has independent memory channels, leading me to believe that identical timings shouldn't even be an issue. However, my system is very unstable. Sometimes it fails to POST after hibernating. Other times it crashes in applications under Ubuntu 12.04. Ubuntu frequently reports errors related to the video card, which is internal to the Intel 3770 CPU. For example, Firefox just reported

FramePoisonBase: 7ffffffff0dea000

InstallTime: 1347398395

Notes: OpenGL: Tungsten Graphics, Inc -- Mesa DRI Intel(R) Ivybridge Desktop -- 3.0 Mesa 8.0.2 -- texture_from_pixmap

FramePoisonSize: 4096

It worked reliably with only one pair and brand of memory. The problem started one week after I installed the second pair and brand. (For the first week it was fine.) Interestingly, this is the second pair of the second brand I've been through--the first pair had a faulty stick.

I'm not sure whether the problem is with the memory itself, an incompatibility, the motherboard's hardware, its configuration, or even the CPU. I have not overclocked anything. I've run memory tests all night without finding a single error.

What steps should I follow to troubleshoot the error?

edit: The BIOS was misconfigured for some reason. I fixed it and it worked fine for the rest of the day. Then I hibernated for the night and it failed to POST in the morning. I had to remove and re-insert a stick (I chose one of the new ones) to get it to work. Could a software bug be responsible for this or does it necessarily indicate that something is still wrong with the hardware?

share|improve this question
    
This has been known to be the case in the past. Don't know about current DRAMs. –  Daniel R Hicks Oct 1 '12 at 17:48
    
Well the most obvious explanation stems from the way in which the two branded memories transfer information. Memory cells are arranged in a massive array that are quickly accessible through the DRAM slots. One single change in the instruction set, that is, the way in which a certain kind of information is processed could lead to an unforeseen issue in data interpretation. It is very possible that the two memory brands have their own optimization instruction sets and thus perhaps is causing this problem. The other explanation is of course, a cosmic ray flipped a bit ^_^ –  AlanTuring Oct 1 '12 at 17:55
    
@AlanTuring: I didn't know memories had instruction sets. Can you recommend an article which explains these things? Shouldn't the motherboard's independent memory channels avoid such problems? –  Emre Oct 1 '12 at 18:11
    
Well, i'm not exactly sure where i could find such an article. But every single micro controller on earth has an instruction set. When you open your Motherboard pamphlet, you will see a table where all accepted DRAM brands are listed and which slots they should go in to. Usually they don't list RAM that is too old(in terms of instruction sets) or of a different type, such as chinese brands that aren't very popular in the Mainstream market. As for a faulty stick of RAM, that is of course a possibility but you ran memtest, nothing showed up. –  AlanTuring Oct 1 '12 at 18:25
    
@AlanTuring - Yeah, Alan, but as you well know every instruction set can emulate every other instruction set, so no problem. –  Daniel R Hicks Oct 2 '12 at 17:59

2 Answers 2

Well sounds like your second brand second pair of RAM is still faulty. To diagnose the problem, just remove your second brand second pair, and stick with the first brand, and see if the problem persists. If the problems goes away, then return your second brand second pair, this time go with another brand.

share|improve this answer

To troubleshoot I'd try to run it with just the first pair again.

If there are no problems, exchange the first pair with the 2nd pair and run for some time with just the 2nd pair.

If you get trouble then, you know something in your 2nd pair is faulty.

If each pair alone runs fine, you can try to add the first pair back into the B-slots (I guess now you have pair 1 as A and pair 2 as B). It may also be a power issue (if your power supply is just barely at the limit, adding more memory could be just the straw that breaks its back).

Generally, my experience is that you can mix brands, but the two within each pair should be made of the same brand. Adding a 2nd pair of a different brand should work and is not unusual.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.