Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I boot Mint in recovery profile it says something about a bug, then it freezes on the line:

Firmware bug DOD is defined but not DOS

I want to access it because I need to restore it like it was the first time I used it. I am suspecting it may be something about the drivers.

Is there any way to restore my system?

Here are my pc specifications:

  • Dell XPS 15z
  • Intel core i7
  • 6 gb Ram
  • Linux Mint 13 maya
  • Cinnamon 64-bits
share|improve this question
add comment

2 Answers

Well there are a few options, first I recommend using a live OS to test your hardware, you can find a article on that here, http://askubuntu.com/questions/194509/diagnoses-live-os.

Secondly if possible, attempt to boot your drive in a computer with the same specs, to see if it's the drive and not your computer.

Try using a live OS in the mean time to see if the files on your drive are accessible, and if there is a live distro of your current linux distro, I am not sure myself as I haven't used that distro, see if you can use a live version of it to somehow do a restore, or at least repair.

share|improve this answer
add comment

I had a similar issue using Fedora 18 and posted a complete (and long) response in Fedora's forum, here.

If you add nomodeset to the GRUB command line, which is a flag usually used in "safe graphics mode", you will also be free of the firmware bug, but you won't get native resolution, only whatever VESA driver can give you (in my case 1280×1024, or something like that). This is considered a solution in most forums, but not for me.

In a nutshell, what I did was add acpi_osi=linux noapic nolapic to the GRUB command line. The first one got me past the firmware bug, but made my keyboard unresponsive, thus the noapic and nolapic. This allowed the Intel driver to be loaded and gave full GUI with native resolution. It took me a while to put this together. Many pages suggested adding acpi=off, acpi=noirq or acpi_osi=. Only acpi_osi=linux worked for me, and I didn't even test acpi=off, I require too much of my laptop to risk a fan not working.

From this guide, I also added i915.i915_enable_rc6=1 i915.lvds_downclock=1 i915.i915_enable_fbc=1 pcie_aspm=force because it supposedly helps the Intel driver with power management and other things, but if I add video=i915:modeset=1 it brings back the error, even with acpi_osi=linux.

This seems to be a problem with newer kernels and the i915 driver for Intel integrated video.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.