Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Strange thing. I'm trying to connect via ssh with command

ssh user@host

It asks correct password for remote host and then nothing happen. I tried to connect to Ubuntu/FreeBSD servers and always got the same issue. Ctrl+C not working here so I must to close terminal window.

Is any way to fix this?

# ssh -V
OpenSSH_5.2p1, OpenSSL 0.9.8r 8 Feb 2011

UPDATE: When I using

ssh -vvv user@host

after asking the password I got this

debug3: packet_send2: adding 16 (len 29 padlen 19 extra_pad 64)
debug2: input_userauth_info_req
debug2: input_userauth_info_req: num_prompts 0
debug3: packet_send2: adding 48 (len 10 padlen 6 extra_pad 64)
debug1: Authentication succeeded (keyboard-interactive).
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug1: Requesting
debug1: Entering interactive session.
debug2: callback start
debug2: x11_get_proto: /usr/X11R6/bin/xauth -f /tmp/ssh-0Y7GGl2NUf/xauthfile generate /tmp/launch-lLdoTI/org.x:0 MIT-MAGIC-COOKIE-1 untrusted timeout 1200 2>/dev/null
share|improve this question

migrated from Oct 2 '12 at 2:08

This question came from our site for professional and enthusiast programmers.

I added a ForwardX11Trusted yes to my .ssh/config file and all works fine. But I can't explain why - so I've put this to comment :) – Roman S Oct 5 '12 at 12:31

I had the same error. After removing XQuartz completely, the error was resolved. Deleting XQuartz from Applications did not fully remove it from my system. Running this command will wipe it completely.

Copy and paste this entire command into your terminal to remove XQuartz.

launchctl unload /Library/LaunchAgents/org.macosforge.xquartz.startx.plist
sudo launchctl unload /Library/LaunchDaemons/org.macosforge.xquartz.privileged_startx.plist
sudo rm -rf /opt/X11* /Library/Launch*/org.macosforge.xquartz.* /Applications/Utilities/ /etc/*paths.d/*XQuartz
sudo pkgutil --forget org.macosforge.xquartz.pkg
share|improve this answer
oh my gosh, you are my hero.. worked perfectly after failing to connect to my Raspberry Pi, among other things. – Erik Jul 30 '14 at 3:11

Try the -vvv option to ssh; that should let you see at what stage it's failing, which is more of a start than what you've got right now.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .