Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a dual boot system with Vista and Ubuntu. I use Ubuntu 99% of the time and have the Windows partition mounted for read/write.

I just ran Diskeeper 2008 while in Vista to "clean up" the disk a bit. I ran a boot time defrag as well as defragging the C: drive a few times.

However, back in Ubuntu I'm no longer able to write to the Windows partition. Any ideas what gives?

A little more info: the partition is NTFS as you'd expect. Running mount on Ubuntu shows the partition is writeable, I think:

/dev/sda3 on /media/OS type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)

Here is my /etc/fstab if it helps. The last line is the Windows partition.

proc /proc proc defaults 0 0
# Entry for /dev/sda5 :
UUID=dc57d1f6-e720-47ee-86e2-c24fa4e24dff / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sda6 :
UUID=fdf33781-b661-4216-a2a2-6fe61e27f399 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/sda3 /media/OS ntfs-3g defaults,locale=en_GB.UTF-8 0 0

UPDATE:

As previously noted in my own answer, I thought I'd solved this by running chkdsk in Windows across the drive. However, I'm still getting occasional errors, mainly when using Transmission (Bittorrent).

If I run nautilus as root, go to a folder on that partition and view the properties of some files, I get this error:

** (nautilus:1177): WARNING **: Couldn't open file:///[filename]: Could not open location; you might not have permission to open the file.
** Message: Error: Could not open file "[filename]" for reading.
gstfilesrc.c(1051): gst_file_src_start (): /GstPlayBin:play/GstFileSrc:source:
system error: Input/output error
share|improve this question
    
Does the output of the dmesg command tell you something? –  CesarB Sep 29 '09 at 1:51
1  
What message does Ubuntu give when you try to write to the partition? For that matter,what program are you using to write? What is the output of "touch /media/OS/newfilename"? –  CarlF Sep 29 '09 at 2:21
    
dmesg command lists hundreds of lines, what kind of thing would I be looking for? dmesg | grep -i error lists nothing. –  DisgruntledGoat Sep 29 '09 at 10:30
    
touch /media/OS/newfile returns touch: cannot touch '/media/OS/newifle': Input/output error –  DisgruntledGoat Sep 29 '09 at 10:31
    
particularly look at a page or two of errors. see if you spot any pattern, where some device gives an error and then there's two or three other lines, and then the same error from the same device shows up again. the device is definitely interesting, tho here it's likely either a) the filesystem, b) the disk, or c) the controller. what error the device is giving is helpful too, especially if it's always the same error. –  quack quixote Oct 5 '09 at 0:12

2 Answers 2

up vote 1 down vote accepted

If Linux detects any errors in a NTFS partition (default type these days for partitions made by Windows), then it will prevent you from writing to it in order to prevent any damage to files. The way to fix it is as you found, boot into windows, run chkdsk. Sometimes you may actually have to run chkdsk, reboot, run chkdsk again, for it to clear everything out.

share|improve this answer
    
As for why there are errors...sounds like your defrag tool is faulty. I would avoid using that tool ever again, a defrag gone bad can destroy your data. –  davr Sep 29 '09 at 22:18

Of course chkdsk under windows is needed. But I suggest additionally clean indexes on this disk. simply open properties for disk C:\ press "Clean disk" or "sweep disk", this is under circle showing disk usage (I have other windows language and can't translate this perfectly), wait some time for windows checking. next press button "clean system files" and wait anogher for checking. finally select what you want to remove. There is another tab "More options". Then clean "System restore and copies in the background".

i see some article about this: http://www.tomshardware.co.uk/forum/244799-45-removing-corrupt-index-file-19604 this explain, that corrupted index is repaired, but originally bug in fs leaves unchanged.

if less system files, then it's better :)

another tech article from ms: http://support.microsoft.com/kb/246026 this point some corruption in MFT, but chkdsk ignore that bugs.

You can 'repair' this by defragment volume with MFT. program MyDefrag do it securely, I'm using this for a lot of time.

Another problem is, your memory may be corrupted. NTFS is very sensitive for this. Run any test, maybe memtest86 is ok, put this running for 1 day.

I have no other idea.

UPDATE

I found another usable (i think) article:

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/XP/Q_27423063.html

but I recommend at first check your RAM

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.