Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Visual Studio 2010, for instance, pinned to my taskbar. I have pinned a solution to it so I can just right-click the VS icon and then choose my solution to fire it up (e.g. from the Jumplist). However, this opens VS in non-administrator mode (which can't access the IIS metabase).

So I have to open VS first and then open my solution.

I know the pinned taskbar app shortcuts are stored at %APPDATA%\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar, but what about the files that are pinned to those shortcuts?

How can I make the solution shortcut (in Jumplist), which is pinned to the VS icon, open VS in administrator mode?

share|improve this question
    
techie007: not quite - that works fine, launching the pinned SLN is what is opening VS in non-admin mode. Thanks though. –  Josh M. Oct 2 '12 at 12:01
    
Can you just go to "C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe" and mark it to always launch as Administrator? –  Ganesh R. Oct 2 '12 at 12:58
    
This is not a duplicate. Read my question and my comment(s) and you will see. I am not a newb - I already set VS to run as Administrator. The Jumplist is not honoring that. –  Josh M. Oct 2 '12 at 13:08
    
@GaneshR.: I tried, but devenv.exe does not have a Compatibility tab. –  Josh M. Oct 2 '12 at 13:08
add comment

2 Answers 2

up vote 0 down vote accepted

See "Option 7" on the following page: http://www.eightforums.com/tutorials/9564-run-administrator-windows-8-a.html

Using the registry, you can set the application to always run as administrator. This solved the jump-list issue for me.

To Set "Run as administrator" in Registry Editor

  1. In Regedit, locate the key HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers.
  2. Add a new String value (or edit the existing one) with the name set to the path to the executable (e.g. for VS2012: C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\devenv.exe).
  3. Set the new key's value to ~ RUNASADMIN (see the link above for more options).
share|improve this answer
    
Can you summarize that link, so that if the link changes or goes dead, your answer is still useful? –  John Bensin Oct 11 '13 at 21:18
    
It works! Thanks. –  Josh M. Oct 19 '13 at 16:20
add comment

You need to make the whole of VS open as admin, to do so open explorer navigate to:

C:\Program Files (x86)\Common Files\microsoft shared\MSEnv\VsLauncher.exe

Right click on it and switch to the properties tab and check the always Run this program as an administrator checkbox.

enter image description here

Then click apply to save the setting.

share|improve this answer
    
I did try to do that before on devenv.exe but there is no compatability tab in that case. I tried what you suggested on VSLauncher but it still opened in non-admin mode. –  Josh M. Oct 2 '12 at 12:00
    
oh, i use this on my PC and it works fine. You are talking about opening files from explorer and jumplists right, like clicking on the .sln file ? –  Taylor Gibb Oct 2 '12 at 12:20
    
Yes, from the Jumplist - sorry - added screenshot to question. –  Josh M. Oct 2 '12 at 12:30
1  
@TaylorGibb Josh M. is using Windows 8. There is some changes in Windows 8 with the Compatibility tab I suppose. –  Ganesh R. Oct 2 '12 at 12:57
    
i will check when i get home, as i am running Windows 8 there. –  Taylor Gibb Oct 2 '12 at 13:01
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.