Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Instant file search (File: Search Files) is bound to Ctrl+Alt+F by default in my installation of Sublime Text 2. I can't find that combination in Default (Windows).sublime-keymap.

On my keyboard layout that conflicts with AltGr+F combination which should be producing a left bracket [.

How can I prevent Sublime Text 2 to use Ctrl+Alt+F for instant file search so that a left bracket is produced as it should be in my locale?

share|improve this question
    
Removed answer because of updated question. Since windows interprets AltGr as Ctrl + Alt. With sublime only, your answer seems like the only way. If you wanted a system wide change to AltGr, you could remap the key with sharpkeys or something similar. Or maybe autohotkey and make it run only when sublime is running. –  d_rail Oct 17 '12 at 22:22
add comment

1 Answer

up vote 1 down vote accepted

Windows understands AltGr as Ctrl+Alt, and therefore AltGr+F will be understood as Ctrl+Alt+F.

A quick workaround is to override the Ctrl+Alt+F to insert the desired character by inputting that shortcut in user key-bindings. Use the menu to get to the key-bindings:

Preferences > Key Bindings - User 

Or directly edit the Default (Windows).sublime-keymap file, and add the appropriate binding to insert your desired character. For example:

[
    { "keys": ["ctrl+alt+f"], "command": "insert", "args": {"characters": "["} }
]
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.