Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a fresh copy of Windows 8 Pro installed from MSDN. I have Google Chrome installed (stable channel) and it is set as my default browser. I even went into Control Panel > Default Programs to ensure that Chrome had all its defaults.

When other desktop applications try to launch my browser they always fail. For example, while trying to install the Android SDK for Windows the installer accurately detected that I did not have the JDK installed. It provides a friendly button to visit java.oracle.com. When pressing this button, nothing happens at all.

You can see that here: http://youtu.be/XXL8GhuWWg0

If it were only that application that was having issues I wouldn't think anything of it but I have been encountering similar issues all over the place. Probably the most irritating one is when visual studio has updates; clicking the update button does nothing.

http://www.youtube.com/watch?v=zwd1mn3TId0

You can see in that screencast that Visual Studio is not able to launch the browser no matter what I click. The update button doesn't do anything and neither do the two links in the update's description.

Any suggestions? I'm assuming it's a Windows issue since it is happening in multiple applications.

UPDATE: Setting IE as the default browser fixes the issue. So it has something to do with it not being able to launch Chrome programmatically. Is it even possible to workaround this bug or do I have to suffer with IE as default for now?

share|improve this question

migrated from serverfault.com Oct 2 '12 at 14:41

This question came from our site for system and network administrators.

1  
This sounds like a problem with Chrome. Have you confirmed with any other alternative browser? –  Ramhound Oct 2 '12 at 16:55
1  
There are two versions of chrome... the metro and the desktop. Could this be the issue? –  KronoS Oct 20 '12 at 4:44
    
@KronoS I tried both of them. –  Alex Ford Oct 20 '12 at 5:09
    
Does it work if you set your default browser to the latest unstable build of Chromium? –  uınbɐɥs Oct 24 '12 at 23:13
    
@ShaquinTrifonoff Nope, just tested it. Chrome dev channel does not work either. I did test with Firefox and that works fine. It's just a Chrome issue it would appear. –  Alex Ford Oct 26 '12 at 3:48

2 Answers 2

Try this:

  1. Set IE as default.
  2. Uninstall Chrome.
  3. Open regedit.exe
  4. Go to HKEY_CLASSES_ROOT and delete all keys starting with Chrome: Registry
  5. Reinstall Chrome and set it as default.
share|improve this answer

Here's how to set Chrome as the default browser in Windows 8:

  1. Press Windows Key + Q to get search box. Type default and you’ll get Default Programs as a result.

  2. Click on that to get this window.

  3. Finally select Google Chrome and click Set this program as default. Click OK.


Here are some different ways:

  1. Check if antivirus is installed or the firewall in your computer is causing this issue (temporarily disable them and check).

  2. According to Google Developers site the current build of Chrome (NaCl Labs) has an ongoing issue with Chrome with 64-bit OS. The common cause for this is the *NaCl64.exe BROKER process*which is buggy and causing issues.

    since adding a MessageBox(0,0,0,0) as the first line of wWinMain in nacl_exe_win_64.cc results in the following: when Chrome is launched with --no-sandbox, two pop-up windows appear when the first NaCl module is launched (once for the lazy launch of the broker, and once for the broker-launched process that runs the NaCl module); with Chrome is launched normally, without --no-sandbox, only one pop-up window appears: the broker process never spawns the 64-bit Nacl process

    Chrome is not launching, Games are not working etc. Per their latest output it says the issue is resolved, but according to Google Chrome Developers, they don't have a Windows 8 bot to test it. The whole details are available now at Chromium Code Reviews.They have in turn provided for the games but it happens other applications also.The Link is provided below http://code.google.com/p/chromium/issues/detail?id=153368

Another ways to try

1)4) Go to the CMD prompt with admin rights copy paste the following

bcdedit /set disabledynamictick yes

this might be a case of Dynamic Ticking

Its been updated from Microsoft Link Below.. http://www.withinwindows.com/2012/06/28/workaround-for-windows-8-freezing-issues/

2)Download the Opensource version of Chrome http://www.softpedia.com/get/PORTABLE-SOFTWARE/Internet/Browsers/Portable-Google-Chrome-Chromium.shtml LESS CRASHES..

3)within the BIOS you need to do this disable SpeedStep and turn off the C-States on the PC

3) Open Desktop Win + I (Settings) Control Panel Programs & Features Turn Windows Features on or off Tick "Hyper-V" (and sub-components, although not required I guess) Reboot (it will reboot twice to reconfigure your system completely)

4)If it still doesnot help with your gmail ID Open up a BuG Report Request at the following link: https://accounts.google.com/ServiceLogin?service=code&ltmpl=phosting&continue=http%3A%2F%2Fcode.google.com%2Fp%2Fchromium%2Fissues%2Fentry

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.