Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Iomega Prestige desktop hard drive (1 TB) which I purchased from Amazon. I connect it to my white Macbook (purchased late 2007, 2.14 GHz with 2 GB Ram), open Disk Utility. I click the single partition on the disk, choose "Mac OS Extended (Journaled)" for the Volume Format and leave the name as-is. When I click "Erase", I get the following error after only a few seconds:

Volume Erase Failed with the error:
The underlying task reported failure on exit

If I try to create a new partition with the same filesystem, I get the following error:

Partition failed with the error:
File system formatter failed.

This is the second disk I've tried this with - I sent the first one back to Amazon thinking it was defective, and they sent me a replacement. Obviously, it's unlikely that I managed to procure two defective drives, so I'm thinking there may be something wrong with my machine.

Another note - I've tried doing the format with the disk connected to both USB 2.0 ports on my machine, as well as connected through a USB hub. The behavior is the same, regardless of how the drive is connected.

share|improve this question
up vote 1 down vote accepted

Just for the sake of having an answer here, this is what ended up fixing the problem:

  • Connected the disk to a windows XP machine
  • Deleted the existing FAT32 partition that the device shipped with using Disk Management under XP.
  • Connected it to the Mac, partitioned and formatted without issue.

I won't make this the selected answer unless somebody upvotes it, and I'll make the question community wiki.

share|improve this answer

Was just about to toss my old iomega 500GB when I thought I'd try one last thing. I used Disk Utility to reformat the partition that wouldn't mound. I selected the "1 Partition" layout, then formatted it to MBR (Master Boot Record) and hit "Apply". To my surprise, it mounted! Then I formatted it again, this time under options I chose "GUID" and under format "Mac Journaled". It finally formatted successfully and is mounted!

share|improve this answer

What was the format of the disk? It's possible that you needed to select the entire drive (that is, repartition the drive) instead of the single partition? Not sure why that would be, but it's usually what I do for brand new drives.

share|improve this answer


I've had this problem before with one other USB drive. I've just got myself a new USB drive which has exactly the same problem and I've finally found the solution.


Disk Utility Screenshot

  1. Select your hard drive.

  2. Select the partition tab. Click on "Volume Scheme". Select "1 partition" or however many partitions you want.

  3. Click on Options...

  4. In the dialog that appears, you want either of the two top options depending on whether you want to be able to boot from an Intel or Power PC mac. (Not shown)

  5. Press OK, then Apply.

Now you're good to go with a lovely Mac OS Extended formatted drive!

share|improve this answer

I just got this error too. I had my Seagate 500GB USB drive connected to a hub that was connected to a USB extender. What fixed it was connecting it directly to the computer(no extender, no hub).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .