Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For some Google search queries executed from the Firefox search bar, or manually by typing in the URL, I get a ''302 Moved'' page. I did a quick virus scan, have checked the hosts file and the plugins and add-ons that are installed in Firefox. Nothing is out of the ordinary. What could be the problem?

These URLs (and any URL with google.com, empty and firefox-a in them) show me a 302 Moved page:

Whereas these URLs work fine:

By default Google redirects my queries to their .nl website, and uses HTTPS. I am currently executing a full system virus scan using Security Essentials. My Firefox plugins were up-to-date. No unfamiliar Firefox plugins or add-ons found. Restarting Firefox did not solve the issue. The issue does not occur in Internet Explorer. The hosts file did not contain any unfamiliar entries.

share|improve this question
up vote 4 down vote accepted

After restarting Firefox with all add-ons and plugins disabled, the issue went away. By enabling each add-on and testing it, I found that DoNotTrack+ is the culprit.

However, I don't know how to solve it. I cannot add google.com to the whitelist as there are no trackers to block. And even so, I am not sure that whitelisting Google would solve the problem.

share|improve this answer
    
You should ask a follow-up question about making Google play nice with DoNotTrack+ if it has not already been asked here :) I think you can also mark your own answer as the answer for the question. – Darth Android Oct 2 '12 at 16:33
    
Was having the same issue with either disconnect or ghostery - didn't have the time to isolate which – eggonlegs Aug 19 '13 at 0:24

Have a look at your Firefox>Add-ons>EXTENSIONS

You may find that there is an active add-on called NoRedirect and it is ENABLED.

For me the "302" problem was gone once I disabled this add-on.

share|improve this answer

This also happens to me; I searched something into the Address Bar, and Google displays their "302 Moved" page.

However, the solution maybe:

  1. Removing the Country Extension

    a. The Country Extension (i.e., google.uk, google.us, google.eu, ...) should be removed from the address bar, if only you are searching through the Address Bar.

    b. The Address Bar should now look like this: http://www.google.com/search?q=Your+Search+Here

  2. Adding the gws_rd=ssl Query String

    a. If you are searching manually (i.e., typing http://www.google.com/search?q=Your+Search+Here into your address bar), try adding the Query String gws_rd=ssl. The URL should now look like this: http://www.google.com/search?q=Your+Search+Here&gws_rd=ssl. (Try removing the &gws_rd=ssl on the Address Bar, it will show the 302 Moved Page)

Hope this works!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.