Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been having the most frustrating time trying to get my desktop computer to wake up from a magic packet. The worst part is, I am almost 100% sure that I have had it working on this computer in the past.

This is what I have attempted so far to no avail:

My BIOS Settings: BIOS

I am running Windows 7 Ultimate x64. My Motherboard is an Nvidia nForce 780i, which comes with two onboard ethernet adapters. I am currently only using one.

On that adapter I have set "Allow this device to wake the computer" and "Only allow a magic packet to wake the computer" I have also went into the advanced setting and made sure that "Wake on Magic Packet" is enabled.

I have also ran wireshark and confirmed that the packets do make it to this computer on UDP port 9.

I have tested it many different ways, via shutdown, hibernate as well as sleep, all to no avail.

I am completely stuck and have no idea where to go from here. Any other ideas would be greatly appreciated.

Thanks in advance.

share|improve this question
    
Have you tried port 7? –  Ryan Oct 2 '12 at 22:05
    
What OS the host you are using to send packets is running? –  Serge Oct 2 '12 at 22:22
    
I have attempted to send packets from my android phone as well as another Windows 7 PC. –  Cheesegraterr Oct 2 '12 at 22:26
    
Take a look at the responses to this question. Specifically the response by Guy Thomas. Windows' own power management may be turning the adapter off when the computer is shut down, so WoL packets could make it to the computer without being "heard." –  Ryan Oct 2 '12 at 22:32
    
Yes, the settings found there are the seetings that I said I had set in the original question... being "On that adapter I have set "Allow this device to wake the computer" and "Only allow a magic packet to wake the computer" I have also went into the advanced setting and made sure that "Wake on Magic Packet" is enabled." –  Cheesegraterr Oct 2 '12 at 22:38

2 Answers 2

up vote 0 down vote accepted

I am a stooge. What I thought were the latest drivers... were not. Updating my drivers solved my problem. Ugh, so much time wasted. Thanks for all your help.

share|improve this answer

WOL can be a pain. Try to send the packet on the broadcast address , for example 192.168.1.255 instead of your actual LAN IP. In the BIOS, make sure you have checked the setting "wake on PCI-e device".

Also, wake on internet doesn't usually work. be sure you're sending your packets from the internal LAN.

share|improve this answer
    
Wake on Internet can work if you have port forwarding set up on the router. –  Ryan Oct 2 '12 at 22:18
    
As I stated... the packets actually do get to my computer. They send the the broadcast address by default. They work when I am on my internal LAN as well as through the internet. –  Cheesegraterr Oct 2 '12 at 22:27
    
@Ryan From previous research, after the computer has been off for a few minutes, the router forgets which computer rightfully owns an IP address, and doesn't forward the request to the correct Ethernet port. The only way I've seen this work is when a broadcast packet is sent to all ports. I was told this has something to do with "ARP tables" To accomplish wake on internet of sorts, I log in to my router and send a broadcast packet from its command line. –  cloneman Oct 2 '12 at 22:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.