Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an old Win Xp box with a 100 PRO/100 VE NIC and connecting to a Win 7 box with gigabit NIC via an ASUS gigabit router and peer to peer. I was getting 76% network utilisation on the XP machine using AUTO as the value for Link Speed and Duplex which is fine.

But I decided to see what would happen if i selected Full Duplex 100Mbps on the XP box. I thought at worst it would be as good as auto detect since the Win 7 box it's transferring to is faster. Instead network utilisation dropped to 0.12% (as in a 10th of a percent) and the transfers just timed out.

No biggie to reverse back to Auto but my question is why is full duplex such a dog? Im not "stuck" but just dont understand. There are only 2 machines here connecting through a router so i cant see how that would cause alot of collisions etc (if thats the problem).

share|improve this question

1 Answer 1

up vote 2 down vote accepted

In Gigabit ethernet, autonegotiation is a mandatory part of the spec.

I suspect on the old card, turning off "auto" turns off autonegotiation entirely. This will prevent the router from working out how to talk to it - it won't just fall back to 10Mbit like 100Mbit ethernet would.

If you put it back to "auto" it will be full duplex anyway.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.