Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

robocopy /"C:\Users\john smith\Documents\Visual Studio 2010\Projects\project\checker\bin\Debug\/" /"C:\Users\john smith\project\Assemblies/" checker.dll

When I run this through the command line it adds an extra C:\ before the filepaths (e.g. C:\Users\john smith\Documents\Visual Studio 2010\Projects\project\checker\bin\Debug\ becomes C:\C:\Users\john smith\Documents\Visual Studio 2010\Projects\project\checker\bin\Debug\).

Why?

share|improve this question
    
looks like / is interpreted as drive root (`c:\`). Those forward slashes seem out of place, what's their intended purpose btw? –  wmz Oct 3 '12 at 14:56
    
It's supposed to escape the quote marks I had to include since my filepaths have spaces. –  MHTri Oct 3 '12 at 15:52

1 Answer 1

up vote 2 down vote accepted

The forward slashes were unnecessary - they were indeed screwing up robocopy's path interpreter. However, when building with Visual Studio's macros you have to add an extra trailing backslash to escape the included backslash of a path, otherwise it will escape the quote mark.

So the working command is: robocopy "C:\Users\john smith\Documents\Visual Studio 2010\Projects\project\checker\bin\Debug\" "C:\Users\john smith\project\Assemblies" checker.dll

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.