Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Ubuntu 12.04.1 installed.
I tried to change the IP address of the interface eth0 in /etc/network/interfaces from to

auto lo
iface lo inet loopback
pre-up iptables-restore < /etc/iptables.up.rules

auto eth0
iface eth0 inet static

sudo service networking status

When I issue:

sudo service networking restart

I get this response:

stop: Unknown instance: 
networking stop/waiting

And IP remains

eth0      Link encap:Ethernet  HWaddr 00:1e:33:71:cd:a4  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::21e:33ff:fe71:cda4/64 Scope:Link
          RX packets:3861 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3291 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3423285 (3.4 MB)  TX bytes:521854 (521.8 KB)
          Interrupt:45 Base address:0x4000 

Only after restart does the IP change. Any ideas?

share|improve this question
This may help… –  kedar Oct 3 '12 at 15:15
But I don't use DHCP... –  Rodnower Oct 4 '12 at 11:15
if you read the article, it doesn't require DHCP, which is disabled in the latter part.. –  kedar Oct 4 '12 at 11:42
Sorry. But any way my interfaces configured to use static IP. –  Rodnower Oct 5 '12 at 11:55

1 Answer 1

up vote 4 down vote accepted

Have you tried:

sudo ifdown eth0
sudo ifup eth0

share|improve this answer
Wonderful!!! It working. But why service networking restart not working?... No ideas?... –  Rodnower Oct 4 '12 at 11:14
I have no clue. I did just think those two commands could do the job. –  FSMaxB Oct 4 '12 at 11:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.