Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So a co-worker is having an issue with connecting to a SVN repo over HTTPS. Here are the details:

OS: Windows 7 Enterprise x64

SVN Client: Tortoise SVN 1.6.6 x64

So, whenever he connects (via a fresh checkout (i.e. a clean svn checkout) or update of existing files (i.e. existing working copy)) to the SVN repo in question, he gets the following error:

Error: Unable to connect to a repository at URL  
Error:  'https://svn.server/svn/path/to/files'  
Error: OPTIONS of  
Error:  'https://svn.server/svn/path/to/files:  
Error:  authorization failed: Could not authenticate to server: could not parse  
Error:  challenge (https://svn.server/svn/path/to/files) 

I had my co-worker try the following things in TortoiseSVN to resolve the issue:

  1. Reset the Authentication Data in Tortoise SVN | Settings | Saved Data for the Authentication Data and URL History,

  2. Checked Proxy Settings in Tortoise SVN | Settings to make sure my co-worker has the same settings that I have on my laptop.

He had the same proxy settings (no settings configured) in TortoiseSVN. Clearing the Authentication Data did not seem to resolve the issue.

I asked my co-worker to log into a spare desktop that is joined to our Active Directory domain with his login credentials and try to checkout a working copy. He was able to check out files, update files, commit files to SVN from the spare desktop. Obviously this issue is not due to my co-worker not having permissions to access the SVN repo since he can communicate with the server from another machine.

So - what / why / where do I have to look on his laptop to resolve this issue? Based on the info contained in the error message, it sounds like something in his SSL certificate on his laptop is screwed up.

I should mention that the SVN server is VisualSVN Server and it is using Integrated Windows Authentication.

Let me know if you need any further info.

Thanks

Richard

share|improve this question

2 Answers 2

Sounds like it this support article could be relevent:
http://www.visualsvn.com/support/topic/00052/

It seems to match all of the conditions that you described. Their fix says:

Since you run VisualSVN Server service under a dedicated user account, 
you have to add SPN manually to Active Directory: 

1.Logon to a Domain Controller as a domain administrator or as a user 
with specific delegated permissions required to modify SPNs. 
For additional information on permissions required to modify SPNs 
please read the "Delegating Authority to Modify SPNs" Microsoft TechNet article. 

2.Start elevated command prompt and enter the following command: 
setspn -a http/hostname.contoso.com CONTOSO\username 
share|improve this answer
    
I read that article, but in the active directory domain at my work I do not have write access to any of the domain controllers on our network so this is not an option. –  Richie086 Oct 3 '12 at 19:59
    
According to their article, the only other fix is to run "VisualSVN Server service under the built-in Network Service user account". If VisualSVN is running under a dedicated account, and cannot be changed to run as the Network Service, the SPN is going to need to created manually. –  Lynn Crumbling Oct 3 '12 at 20:07

As far as I understand both of the machines are located in the same Active Directory domain. The first steps you should perform to troubleshoot the issue:

  1. Check the VisualSVN Server log. Do you have any errors there? What are the errors?
  2. Check the Windows Security log. What events are logged there when authentication fails?
  3. Can he authenticate with a web browser? E.g. with IE and with FF.
  4. Do you have the same version of TortoiseSVN on your (or the spare one you've mentioned) and your co-worker's machine?
  5. What version of VisualSVN Server do you have installed?

Knowing these details you can troubleshoot the authentication issue much faster.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.