Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

OK, I've got this problem again, only this time the problem only seems to affect Firefox and Thunderbird. Rebooted several times and tried resetting to the last restore point, but that didn't work. Tried setting a new Firefox profile, and that didn't work either.

The symptom is that you click on the Firefox or Thunderbird icon, the process appears in the Process Explorer list, but the window never opens. Curiously, if Firefox has been "started" this way, Internet Explorer hangs starting until I kill the Firefox process.

Any ideas? I suppose the next thing to try is uninstalling and reinstalling Firefox/Thunderbird, but this whole thing is getting old.

The box is a Sony Vaio running Windows Vista. It was completely restored from scratch less than two weeks ago, after the last fiasco. (I'm suspecting that my aborted install of Acronis True Image may have mucked things up this time.)

Sigh! Another symptom:

It occurred to me to try printing something, but if I open "Printers" it just sits there "searching". So something is rotten in the bowels of Windows.

Minor update: It occurred to me to kill Internet Explorer (where I'd attempted printing). Then Printers comes up fairly quickly -- with no printers defined. Clicking "Add a printer" does nothing.

Update: Well, following this suggestion to stop and restart the print spooler brought the printers back.

And, wonder of wonders, Firefox now starts OK. Stopping and restarting the print spooler!!

Epilog: For some reason I now need to stop/restart the print spooler after every reboot. No real biggie, just another Windoze irritation.

share|improve this question
Can you find any other problematic apps? Just click through a few in your start menu just to ensure this only Firefox and Thunderbird. Does the event log show up any interesting events? Can you go and look at the list of last installed software to see if there's something interesting there? You should look here for something you also installed lately on your previous install. Did you copy the profile over? Can you check if your hard drive's S.M.A.R.T. status is still fine? – Tom Wijsman Oct 3 '12 at 20:18
@TomWijsman -- The last "suspicious" thing I did before this was to run the Acronis True Image uninstaller. Apparently Acronis has really mucked up the last several releases of True Image, and this is a likely symptom. – Daniel R Hicks Oct 3 '12 at 20:44

Just follow the link and perform the required procedure.

share|improve this answer
Safe mode comes up to the dialog, but Firefox never starts. – Daniel R Hicks Oct 3 '12 at 18:30

Another possibility is that the profile is corrupt. If the profile is not of use to you at this time, you can run -p to find the profile and delete it. You can also run this command that will delete the profile config file and see if it helps: del "%appdata%\mozilla\firefox\profiles.ini"

share|improve this answer
I created a recovery profile. Firefox will come up to the "Select Profile" menu, but won't start with either profile. – Daniel R Hicks Oct 3 '12 at 18:28
@Daniel: Try renaming the mozilla folder so you start off fresh to see if that does something. – Tom Wijsman Oct 3 '12 at 20:19

Oh yes, this is a common firefox bug and is being worked on for future versions of Firefox. All of have to do is this: Go to Task Manager, click on processes, and find all firefox.exe processes. Then right click on them and choose "End Task", do that for all firefox.exe processes listed. Then open firefox again.

share|improve this answer
Do the same with Thunderbird. – Josiah Oct 3 '12 at 17:52
Very familiar with that scenarion -- did that, multiple times. Rebooted several times. Won't start, no way, no how. – Daniel R Hicks Oct 3 '12 at 18:27
...Well, this is a problem. I have never encountered such a bug. Perhaps it's corrupted. Have you tried reinstalling firefox? – Josiah Oct 3 '12 at 19:57

Try going into services and stopping the print spooling service. You may get the following error:

Windows could not stop the Print Spooler service on Local Computer.

Error 1053: The service did not respond to the start or control request in a timely fashion.

but Firefox should start working again. The spooler service actually does stop, but you can restart it and Firefox will keep working.

share|improve this answer
You'll notice that I figured that out back in October. – Daniel R Hicks Mar 19 '13 at 19:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .