Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to fix an old laptop running XP, it was all working fine until fairly recently but it will no longer connect to the web (via Chrome, Firefox or IE). I can ping out to the IP address for google, yahoo, etc. and ping the DNS server that ipconfig tells me it is using and works when accessed from other laptops but nslookup fails giving 'DNS request timed out' errors.

I have tried disabling the firewall but it makes no difference. The same problem occurs with both wired and wireless connections but both work with other laptops so it's a problem with the laptop itself not with the internet connection it is trying to use. It has the same problem trying to connect via a completely separate connection too.

Unfortunately, I don't have any XP disks handy so I can't try a repair install and someone had the great wisdom to disable system restore points on this laptop so I can't try backing it out to a restore point.

What can I try next? What could be the problem?

Thank you.

Edited to add:

Ping to google.com doesn't work, ping to their IP is fine

DNS settings are coming from the ISP, and work fine on other laptops, replacing them with public DNS server settings doesn't help.

Telnet to the DNS server works from other laptops, but not from the laptop that is not working. I tried RootkitRevealer but it showed nothing untoward.

share|improve this question
1  
So you can ping google with its IP, but can you ping using the hostname? –  MaQleod Oct 3 '12 at 19:07
    
Can you telnet to port 53 of the dns? If not, and you CAN telnet to the same IP from other boxen, it makes me wonder if you've got some sort of rootkit installed. –  Lynn Crumbling Oct 3 '12 at 19:13

1 Answer 1

which DNS server are you connecting to?

Try changing the primary DNS to 4.2.2.3 and secondary to 4.2.2.7 (both are public DNS servers).

Are you getting DNS from your router (for example is DNS the same IP as your routers IP?), from your ISP via DHCP? Are you setting DNS statically?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.