Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm a first time user of sshfs, trying to use it to give myself access to a remote file system.

$ sudo sshfs username@servername.edu:/home/csg/username/low /local/servername

When I issue this command, everything seems to work fine, but I don't get any sort of directory access in my /local/servername folder. Anybody know what I need to do next? Or have some good documentation on how to use this?

I'm running Ubuntu 9.04.

Thanks!

share|improve this question
    
did you add your username to the fuse group? –  John T Sep 29 '09 at 4:52
    
@john 'sudo' .. what more rights does he need? –  akira Sep 29 '09 at 5:15
    
@carl: what does 'mount | grep servername' give you? is it at least mounted correctly? –  akira Sep 29 '09 at 5:18
    
@akira, it returns nothing –  Carl Sep 29 '09 at 21:56
    
then it looks like 'everything seems to work fine' is a false claim :) 'mount' should list all (including fused handled) mounted nodes. i would look into that problem first –  akira Sep 30 '09 at 6:54
add comment

3 Answers 3

You have issued the sshfs command with sudo - which means the files mounted under /local/servername are only readable by root.

So you'll either need to do 'sudo bash' to get a root prompt which will allow you to browse it's content, or you need to do as John T suggested in the comments, and make sure your own user is a member of the 'fuse' group, and then NOT use the sudo prefix when issuing the sshfs command.

Note: Should you choose the latter option (and you should) you will find out that the mounted file system's contents are not visible to root either. FUSE mounted file systems are very user specific.

share|improve this answer
    
i dont think its a problem of "permissions" but rather a "nothing is mounted and thus nothing can be accessed" problem. –  akira Sep 30 '09 at 6:56
add comment

You can add your username to the group fuse like so:

sudo adduser YourUsernameHere fuse

that should make the files visible to you.

share|improve this answer
add comment

By default fuse file systems are only accessible to the user that mounted them. By doing sudo, this is effectively the root user.
Try just mounting it as your user (without sudo) or with -o allow_other (but this needs to be enabled in /etc/fuse.conf).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.