Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a FreeBSD 9.0 installation which works fine. The only problem is cpan. I tried forums.freebsd but didn't help much.

Here is some cli output:

[user ~]$ cpan --version
Cannot load ExtUtils::MakeMaker: Can't locate ExtUtils/MakeMaker.pm in @INC (@INC contains: /usr/local/lib/perl5/site_perl/5.12.4/mach /usr/local/lib/perl5/site_perl/5.12.4 /usr/local/lib/perl5/5.12.4/mach /usr/local/lib/perl5/5.12.4 /usr/home/atma) at (eval 9) line 1.
BEGIN failed--compilation aborted at /usr/local/lib/perl5/5.12.4/BSDPAN/ExtUtils/MakeMaker.pm line 17.
Compilation failed in require at /usr/local/lib/perl5/5.12.4/CPAN.pm line 46.
BEGIN failed--compilation aborted at /usr/local/lib/perl5/5.12.4/CPAN.pm line 46.
Compilation failed in require at /usr/local/lib/perl5/5.12.4/App/Cpan.pm line 183.
BEGIN failed--compilation aborted at /usr/local/lib/perl5/5.12.4/App/Cpan.pm line 183.
Compilation failed in require at /usr/local/bin/cpan line 8.
BEGIN failed--compilation aborted at /usr/local/bin/cpan line 8.
[user ~]$ locate MakeMaker.pm
/mnt/storage/backup/ebox-backup/usr/lib/perl5/5.12.4/ExtUtils/MakeMaker.pm
/mnt/storage/backup/ebox-backup/usr/lib/perl5/vendor_perl/5.12.4/ExtUtils/MakeMaker.pm
/mnt/storage/ebox-backup/usr/lib/perl5/5.12.4/ExtUtils/MakeMaker.pm
/mnt/storage/ebox-backup/usr/lib/perl5/vendor_perl/5.12.4/ExtUtils/MakeMaker.pm
/root/.cpan/build/ExtUtils-MakeMaker-6.62-WA5oA9/blib/lib/ExtUtils/MakeMaker.pm
/root/.cpan/build/ExtUtils-MakeMaker-6.62-WA5oA9/lib/ExtUtils/MakeMaker.pm
/usr/local/lib/perl5/5.12.4/BSDPAN/ExtUtils/MakeMaker.pm
/usr/ports/lang/perl5.14/files/patch-cpan__ExtUtils-MakeMaker__lib__ExtUtils__MakeMaker.pm
[user ~]$ 

When I try to install p5-ExtUtils-MakeMaker via ports it fails. Perl seems to work fine.

Any ideas on how to fix this problem?

UPDATE: Then I try to isntall ExtUtils-MakeMaker

[user /usr/ports/devel/p5-ExtUtils-MakeMaker]$ sudo make install clean
Password:
===>  Extracting for p5-ExtUtils-MakeMaker-6.62
=> SHA256 Checksum OK for ExtUtils-MakeMaker-6.62.tar.gz.
===>   p5-ExtUtils-MakeMaker-6.62 depends on file: /usr/local/bin/perl5.12.4 - found
===>  Patching for p5-ExtUtils-MakeMaker-6.62
===>   p5-ExtUtils-MakeMaker-6.62 depends on file: /usr/local/bin/perl5.12.4 - found
===>   p5-ExtUtils-MakeMaker-6.62 depends on package: p5-ExtUtils-Manifest>=1.58 - not found
===>    Verifying install for p5-ExtUtils-Manifest>=1.58 in /usr/ports/devel/p5-ExtUtils-Manifest
===>  Extracting for p5-ExtUtils-Manifest-1.60
=> SHA256 Checksum OK for ExtUtils-Manifest-1.60.tar.gz.
===>   p5-ExtUtils-Manifest-1.60 depends on file: /usr/local/bin/perl5.12.4 - found
===>  Patching for p5-ExtUtils-Manifest-1.60
===>   p5-ExtUtils-Manifest-1.60 depends on file: /usr/local/bin/perl5.12.4 - found
===>   p5-ExtUtils-Manifest-1.60 depends on file: /usr/local/bin/perl5.12.4 - found
===>  Configuring for p5-ExtUtils-Manifest-1.60
Cannot load ExtUtils::MakeMaker: Can't locate ExtUtils/MakeMaker.pm in @INC (@INC contains: /usr/local/lib/perl5/site_perl/5.12.4/mach /usr/local/lib/perl5/site_perl/5.12.4 /usr/local/lib/perl5/5.12.4/mach /usr/local/lib/perl5/5.12.4 .) at (eval 1) line 1.
BEGIN failed--compilation aborted at /usr/local/lib/perl5/5.12.4/BSDPAN/ExtUtils/MakeMaker.pm line 17.
Compilation failed in require at ./Makefile.PL line 7.
BEGIN failed--compilation aborted at ./Makefile.PL line 7.
*** Error code 2

Stop in /usr/ports/devel/p5-ExtUtils-Manifest.
*** Error code 1

Stop in /usr/ports/devel/p5-ExtUtils-MakeMaker.
[user /usr/ports/devel/p5-ExtUtils-MakeMaker]$ 

When I try to located it though:

/root/.cpan/build/ExtUtils-MakeMaker-6.62-WA5oA9/blib/lib/ExtUtils/MakeMaker.pm
/root/.cpan/build/ExtUtils-MakeMaker-6.62-WA5oA9/lib/ExtUtils/MakeMaker.pm
/usr/local/lib/perl5/5.12.4/BSDPAN/ExtUtils/MakeMaker.pm
/usr/ports/lang/perl5.14/files/patch-cpan__ExtUtils-MakeMaker__lib__ExtUtils__MakeMaker.pm
share|improve this question
    
what is the error when you install MakeMaker? – arved Oct 4 '12 at 9:37
    
I added the output. – atmosx Oct 5 '12 at 17:06
    
Do you have a compiler or development tools installed? Something like build-essential? – Mike Oct 8 '12 at 23:00
    
Yes. I manage to solve this issue by using 'portmanager' to re-install perl! – atmosx Oct 12 '12 at 17:26
up vote 2 down vote accepted

Solved by forcing perl re-install using portmanager.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .