Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I connect to my Windows 8 Professional machine via Remote Desktop (RDP) I almost always get my WiFi connection broken.

The setup:

T61P Lenovo Laptop + W8 at home
Wireless Router with NAT forwards connections to that machine
Windows 7 laptop at work connecting to the home laptop

When I connect, very often I get to login and suddenly connection is lost and I cannot reconnect again. When I get home I find my WiFi connection is still connected to the Access Point but does not function. Can't even ping the router.

What is strange is that disabling wireless with the hardware switch and enabling it again doesn't help. The only way to make it works again:
- Reboot
- Disable wifi with hardware switch AND disable the network card in Device Manager, then enable both

I did not have this problem on the very same laptop when it was running Windows 7.

Any hint how can I find where the problem is?

share|improve this question
    
Could you try disabling the firewall in Windows 8? Perhaps it has decided the router is attacking it and has blocked connections from it. –  Paul Oct 23 '12 at 0:26
    
Check that you have the latest wireless drivers for your device. –  Mufasa Oct 27 '12 at 19:30

1 Answer 1

Try the following suggestions:

  • Install all the latest drivers from the Lenevo's website. (esp. network and graphics drivers)
  • Install all Windows updates
  • Disable firewall
  • Close all network-related apps and check if the issue persists. If it doesn't maybe some app might be the cause.
  • Upgrade the router's firmware
  • If none of these suggestions work, do a clean install.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.