Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The applications in question are:

  • nUnit 2.6.1: "NUnit requires .NET 2.0, .NET, 4.0 or Mono to be installed as a prerequisite."
  • PowerCommands for VS2008: "Please install .NET framework 3.5"

The versions of .NET I currently have on my system are:

  • 3.5.1 (Windows 7 feature)
  • Compact framework 2.0 SP2
  • Compact framework 3.5
  • Framework 4 client/extended

I've tried removing all frameworks and Visual Studio 2008 (via the "Uninstall or change a program" tool) and reinstalling them (first via Windows Update, then installing VS2008). However, I get the same errors.

Can anyone help?


(Windows 7 SP1)

share|improve this question
You have none of the support .NET Framework versions installed. You need to installed either .NET Framework 2.0. Visual Studio 2008 does not support .NET Framework 4.0* – Ramhound Oct 4 '12 at 10:58
Tried installing 2.0, but complains that I have a higher version (3.5) – johnnyturbo3 Oct 4 '12 at 11:51

I too faced same problem, to solve what I did is

Go to RUN -> CMD -> Open commandPrompt with 'Run As Administrator'
change the directory path to your Nunit location
ex: >D:\softwares
now type the Nuint complete name with extensions
ex: D:\softwares> NUnit-2.6.3.msi , hit ENTER

You will be prompted with similar NUnit Installation Next, Next...
Nunit installed successfully ...

This will work only if you are already installed with required .NET frameworks like ( .NET 2.0, .NET, 4.0 or Mono)

share|improve this answer
this works for nunit.3.2.0.msi too – oleksa Mar 10 at 15:43

I had the same error installing NUnit 2.6.0 on Windows 7, despite the fact that I have all the .NET Framework versions up to 4.0 installed (1.0, 1.1, 2.0, 3.0, 3.5, 4.0).

I got past the error message by running the installer with administrator privileges (Right click > Run as admin).

share|improve this answer
Used this post to install as admin:… – jacoblambert Apr 27 at 19:47

I rather suggest you properly run a windows update to fix the problem. Windows 7 are the best reliable built-in .NET framework 3.5 or even higher. So, try updating your system (if the update really works) and you will see it working.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.