Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Network admin allowed me to read-access only 1 file from a subfolder of a shared folder on a server and I don't have permissions to even view upper level folders, but when I open that folder I can see all files in it.

I open command window under my user name on my PC and then try to copy that file on my PC:

when I use copy - it works

when I try xcopy - it says "File not found".

when I try robocopy - it says "Access is denied".

How come "copy" is the best tool from those 3 in my situation ? What can I do to make other tools to work in this case ?

share|improve this question

migrated from stackoverflow.com Oct 4 '12 at 22:38

This question came from our site for professional and enthusiast programmers.

    
which were the xcopy parameters you were using ? – BrOSs Oct 4 '12 at 15:18
    
without parameters – alpav Oct 4 '12 at 18:39
    
What version of Robocopy are you using? – Kevin Fegan Jan 29 '14 at 23:33

try this

XCOPY \\Server\Folder\yourFile.txt C:\YourReportFolder\  /C /S /D /Y /I

Example:

XCOPY "\\MX0010\Folder\YourFile.xlsx" "C:\Users\User\Desktop\Reports\" /C /S /D /Y /I

Regards

share|improve this answer
    
This did not help, if I replace xcopy from your example with copy and remove /C /S /D /Y - it works. xcopy still gives same error "File not found". Putting backslash at the end or wrapping source and destination in quotes did not make any difference. – alpav Oct 4 '12 at 20:24

Have you tried mapping your source folder to drive letter first and then use the drive letter in the copy script? It shouldn't matter, but I have seen stranger work-arounds.

 net use f: \\Server\Folder
 XCOPY "f:\YourFile.xlsx" "C:\Users\User\Desktop\Reports\" /C /S /D /Y /I
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .