Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 3 screens connected to my video card. Two of the screens use the DVI connection and the third uses the HDMI connection. The screen on the HDMI connection has integrated speakers, so I want to use its speakers, but without having the desktop expanded to it.

The HDMI display is 1920x1080, the DVI displays are 1920x1200.

When the desktop is expanded to it, I can hear audio, but if I want to display the desktop only on the DVI connection screens, there's no audio any more, which is normal and makes sense.

But I wonder if there is a way on Windows 7 to use the audio output of a HDMI display device without expanding the desktop to it. Consider that the display device doesn't support external audio input, so, is there a way to hear audio on a HDMI display device with integrated speakers without actually expanding the desktop to it?

It doesn't allow me to set HDMI as a copy of one of the DVIs. I also tried disabling the display in the display settings and setting HDMI as default device. Even if the audio output is set to HDMI, the display doesn't play audio.

share|improve this question
    
Quick question: why? –  Canadian Luke Oct 5 '12 at 6:30
    
Because I want to use the integrated speakers of the HDMI display device without wasting GPU on it. –  IneedHelp Oct 5 '12 at 6:33
    
can't you set the HDMI as a copy of one of the DVIs –  ratchet freak Oct 5 '12 at 7:18
    
@ratchetfreak That sounds like a good idea, unfortunately it doesn't allow me to. Also, the HDMI display is 1920x1080, while the DVI displays are 1920x1200. –  IneedHelp Oct 5 '12 at 7:42

2 Answers 2

up vote 4 down vote accepted

Try disabling the display in the display settings, then open sound options and set HDMI as default device.

From our comments, It seems that the GPU is responsible for the signal that is sent to display, therefore it does not seem possible to only get audio from a GPU's output.

share|improve this answer
    
That's what I did first time. Even if the audio output is set to HDMI, the display doesn't play audio. –  IneedHelp Oct 5 '12 at 7:09
    
Hmm, I see. Well the issue may be that the gpu is responsible for the signal that is sent to the monitor, therefore if no display is in use the audio may be simply switched off. I don't have a further solution, sorry. –  LukeStoneHm Oct 5 '12 at 7:18
    
Yeah, you're right. Audio to the HDMI device is sent through the GPU. Please add your latest comment to your answer, I'm going to mark it as an answer. –  IneedHelp Oct 5 '12 at 7:53
    
It is absolutely possible to do, however... assuming your video card's drivers support such a function. Nothing says it HAS to have an active display to also receive audio. From an engineering standpoint "Well, that's pointless. Why would we send audio to something that doesn't have the display?" –  UtahJarhead Oct 8 '12 at 12:40
    
There is yet another problem. HDMI doesn't support audio only. The monitor won't play the audio without a video signal. Even if you use an external AV receiver, most receivers won't even play audio from an active video input unless a HDMI display is attached and switched on. –  Locutus Feb 14 at 12:42

I know this is an old one here, so sorry for reviving the dead..

I'm just thinking, from the standpoint that the GPU settings are allowing you to select HDMI as an audio output even though HDMI display is disabled, perhaps your issue is not with the GPU or computer?

Here's where I'm coming from: I have a old TV that I periodically use with my notebook via HDMI to listen to music and watch movies when the family is absorbed in something I'm not interested in on our good new TV. When I connect it up though, I have to turn off display sleep, because when the computer stops sending a video signal, the TV goes to sleep and shuts off the audio, even if it is still playing.

So perhaps the issue for you is the display going into low power mode, not the computer itself.

You've probably already found a set up that works for you by now, but hopefully anyone else who stumbles across this in the search for workarounds may find this point of view useful.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.