Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a Word 2010 document that I'm trying to convert to a PDF with "Save As...", preserving hyperlinks. Something odd is going on:

  • Hyperlinks on inline text, or images that are inline, work fine.
  • Hyperlinks on images with layout "in front of" text don't work in the PDF, same for hyperlinked drawing shapes.

What I'm trying to do is make a "clickmap" image by putting an image on the page and overlaying parts of it with transparent shapes that hyperlink to different URLs. This isn't working, and the transparency has nothing to do with it - hyperlinks in the PDF seem only to work on "in line with text" elements.

Am I missing something, or is there a better way to do this?

share|improve this question
add comment

3 Answers

I just pasted a screenshot in Word 2010, then used Insert / Text Box / Simple Text Box, changed its properties to no outline and no fill, then set it to link to a URL. Did the same with another non-overlapping text box positioned elsewhere on the image. Finally, I saved as PDF using the Standard (not Minimum Size) option (also see screenshot below). The links work perfectly in Sumatra PDF. If you repeat the steps and it still doesn't work, most likely there's something wrong with your PDF viewer.

enter image description here

share|improve this answer
    
I tried a simple text box with hyperlink and Standard PDF option - still doesn't work for me. My PDF reader is Adobe Acrobat, and there's many things wrong with it IMO but it's the one I have to design for. –  Bristol Oct 7 '12 at 20:45
    
@Bristol: I added a screenshot above for my Standard option settings. If those don't help, it's a problem with Adobe Acrobat. I haven't touched Adobe's Reader in ages, so no idea how to fix this, or if it can even be fixed without Adobe's help. Maybe you can look into Reader's security/permissions-related settings - there might be something in there that's blocking these links. –  Karan Oct 7 '12 at 20:52
    
Still doesn't work for me, sorry. In the end, I cut the image into rectangles, inserted them in-line with the text and assigned different hyperlinks to them. Works fine even in Adobe Reader. –  Bristol Oct 8 '12 at 14:08
add comment

You save it as a Macro Enabled Document then convert that to PDF. It pulls over the directives for the hyperlinks.

share|improve this answer
add comment

I have noticed the same problems as noted above with one HUGE exception. I have several documents that were originally created in 2007 but now are updated in 2010.

Some of them save as PDF with no problems in the image Hyperlinks. But others drop the hyperlinks from the images. I know that it is some setting.

I noticed that if I use a document that works, delete everything out of it, (keeping the settings etc) then copy into the document the other documents contents, it converts fine.

So this means that it is NOT the contents that are the problem. Instead it is something to do with the settings on one document compared to the other.

I Just figured out what the difference was. The docs that worked were (.docx made with 2007) and the ones that did not work were (.doc)

When I took a document that was converting well (.docx made with 2007 & updated with 2010) and changed it to a (.doc) file, it no longer saved the image hyperlinks.

However, when I converted a (doc) to (Docx) in 2010, it did not work either.

So in order for the word 2010 to pdf hyperlink images, you need a (Docx) document created by 2007, and then save to pdf with word 2010.

TRY taking old (docx) files originally created with word 2007, delete all the contents, then copy and paste what ever you want into the "Shell" and I think that it will save to pdf with working hyperlinks. (It did for me)

Hope this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.