Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Im having problems installing SOAPUI on my Ubuntu 12.04. It throws: "Could not display the GUI. This application needs access to an X Server"

My java version is: java version "1.7.0_07" Java(TM) SE Runtime Environment (build 1.7.0_07-b10) Java HotSpot(TM) 64-Bit Server VM (build 23.3-b01, mixed mode)

so i think this is not the problem.. Any help will be appreciated.

share|improve this question

migrated from Oct 5 '12 at 8:45

This question came from our site for professional and enthusiast programmers.

up vote 2 down vote accepted

This is a very late reply, but I wasted a lot of time trying to sort this, so I hope someone else will find it useful.

The bundled JRE is a 32-bit version, and it has a dependency on libXtst. On my 64-bit Fedora box, installing the following package fixed it:

# yum install libXtst-1.2.0-3.fc17.i686

Make sure to install the 32-bit version of libXtst (the .i686 in the end).

share|improve this answer

so i think this is not the problem..

Why? Because you have Java installed? X11 is something entirely different. Please provide a bit more information, like is this running on your local desktop, or a remote machine. Do you have X11 running? Output of xdpyinfo, etc.

share|improve this answer
no, i thought that because i have read that this problem might happend if you doesnt have installed in your machine the oracle java.. Im running it on my local desktop. The xdpyinfo output is: (and goes on..) name of display: :0 version number: 11.0 vendor string: The X.Org Foundation vendor release number: 11103000 X.Org version: 1.11.3 maximum request size: 16777212 bytes motion buffer size: 256 bitmap unit, bit order, padding: 32, LSBFirst, 32 image byte order: LSBFirst number of supported pixmap formats: 7 – user1683628 Oct 4 '12 at 15:32
@user1683628: Now the next question: Do you start SOAPUI under your user session, or as a different user, in a different session (i.e. through su, sudo)? – datenwolf Oct 4 '12 at 16:35
yes i runned the instaler with sudo. also i could install it with -c option, but then SoapUI doesnt run, so maybee is because could not display the gui also – user1683628 Oct 4 '12 at 17:04
There's your problem: sudo doesn't hand over the X authentication token, programs started there won't be able to open a connection to the X server. The authentication token usually resides at ${HOME}/.Xauthrority. E.g. it may be /home/foobar/.Xauthority. So open a sudo shell (sudo -s), then therein add the right authority environment (export XAUTHORITY=/home/foobar/.Xauthority), now you should be able to run the installer from within that shell. You must replace /home/foobar with your own home directory of course. – datenwolf Oct 4 '12 at 18:21
had no luck with this, the XAUTHORITY is now linked to my user, but still cant display the GUI – Bruno Oct 5 '12 at 13:05

Make sure you've downloaded (64-bit version) installer.

I've had the same issue when trying to run (32-bit version) on x64 Ubuntu by mistake.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.