Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using a router and an AP on my home network. If i connect to my AP then the router gives the computer an IP through DHCP. The problem is that computers that connect to the router are not visible to the computers that connected through the AP.

How can I fix this?

share|improve this question
    
it would be useful to know if you can ping the computers on the different devices. AP device computer to router device computer. –  nelaar Oct 5 '12 at 13:17
    
It would also be useful to see the routeing tables on your different computers. netstat -r. –  nelaar Oct 5 '12 at 13:25
    
do you have internet access from all your devices. We need a lot more info to try and figure this problems out. –  nelaar Oct 5 '12 at 13:43
add comment

2 Answers

You didn't mention your Operating System Name. I think that you are using Windows.

If it XP or older check the WORKGROUP name. If it is windows 7 check WORKGROUP name and also what you choose as network type like HOME NETWORK, WORK NETWORK, PUBLIC NETWORK.

Also check visibility of network and computer.

share|improve this answer
    
The System is win7, I didnt mention it, but i've tagged it. Where do i check the workgroup name? –  SnapDragon Oct 5 '12 at 12:05
    
Right click My Computer -> Properties, There will be workgroup name. For Sharing options Control Panel->Network and Internet –  Kumar Oct 5 '12 at 12:17
    
It says WORKGROUP. Just like the laptop and the streamer (they connect to AP), but they dont see the desktop, that is wired to the router. –  SnapDragon Oct 5 '12 at 12:20
add comment

The problem is actually a feature of some routers. It is called lan isolation. It allows you to keep certain network ports / devices isolated from others.

Depending on your specific router (need more info) the configuration can be quite different. Essentially you need to put all you ether net ports and wifi connection into the same lan or disable isolation of the different connections.

http://www.tomshardware.com/forum/28679-42-create-isolated-etwork-router

Have a look at this doc http://documentation.netgear.com/dg834n/enu/202-10197-02/Wireless.4.3.html

Wireless Isolation
This feature is disabled by default. If it is enabled, wireless stations cannot communicate with each other or with stations on the wired network.

UPDATE Based on your comment I went and looked at the manuals for the two devices you have. I think this is less a problem of Lan isolation settings, and more a routing problem between devices.

TL-WR841N/TL-WR841ND

In the following sections.

4.6.4 Wireless Advanced
Choose menu “Wireless → Wireless Advanced”, you can configure the advanced settings of your wireless network.
Enabled AP Isolation - This function can isolate wireless stations on your network from each other. Wireless devices will be able to communicate with the Router but not with each other. To use this function, check this box. AP Isolation is disabled by default.

If that does not resolve the problem. It might also be necessary to do some routeing configuration on your devices.

4.12Advanced Routing 4.12.2 System Routing Table
Choose menu “Advanced Routing → System Routing Table”, and you can views all of the valid route entries in use. The Destination IP address, Subnet Mask, Gateway, and Interface will be displayed for each entry

Edimax 6254n

You may need to disable dhcp server on this device and set it up with a static ip address, and route to your actual router. On your router you would set up a static ip address to this device. This would let your router do all the dhcp set up for the whole network.

Have a look at this section of the manual.

3-3 LAN (Wired)

share|improve this answer
    
I have an Edimax 6254n as the AP and TP-Link WR841n as the router. The option of isolation is auto disabled when i select to enable wds-bridge in the TP-Link Router. –  SnapDragon Oct 5 '12 at 12:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.