Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I wanted to ask this question for a while now, and it may just be nothing, but it's bugging me like crazy.

At the moment i have a win2008 server up, which has several dedicated shares for specific purposes. For example, one is specifically for software storage, another for music, another for pictures and another for movies.

All of this is accessed through the wireless lan at home. So whenever I am using my laptop at home, I can just access the mapped share and get stuff off it, or watch videos or play music from the server itself. The wireless speed of the lan is more than sufficient to handle this, and I have so far successfully watched videos stored on the server using a windows laptop.

However, whenever I use my linux laptop (running Mint 13 Maya) the video stream stops several times during playback and this freeze lasts for a good 60 seconds if not more.

To be specific, the distance between the two test machines (win7 and Mint 13) and the wifi router is 1 meter. The server is connected to the router via ethernet cable so distance is not exactly an issue here. Each machine has it's own user login for the server in order to map the shared drive.

So my long preface leads to this - why in god's name does a win7 laptop stream a video flawlessly from the server, where the linux laptop has to freeze the video a couple of times while doing the same task.

Both machines are running VLC by the way. Both machines have this spec:

i3 Quad core - 2.3GHz, 8GB Ram, Intel integrated video. 250GB HDD.

I might be missing something very obvious, but it makes no sense to me.

Could anyone offer any advice or explanation as to why this might be happening? Could you suggest any troubleshooting steps please?

share|improve this question
    
Try going further away from the router by another meter or 2. The reason I say this is because sometimes 2 RF antennas that close together can cause some big issues in the signal itself. Will it fix your woes? I don't know, but it's worth a shot. –  UtahJarhead Oct 5 '12 at 13:18
    
Is the Linux laptop being used in the same location as the Win7 laptop? –  UtahJarhead Oct 5 '12 at 13:18
    
Well they never run at the same time, but when i test, i connect the win7 laptop first, run a vid, then do the same with linux. While one is running, the other is in "sleep" mode. Also both are on a coffee table in the middle of my room. pretty much same position, yes. –  Anon Oct 5 '12 at 13:21
    
What wireless chipset in the Linux machine? –  UtahJarhead Oct 5 '12 at 13:27
    
Both laptops are identical, both use this - Ralink RT3592 802.11a/b/g/n 2x2 WiFi Adapter –  Anon Oct 5 '12 at 13:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.