Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on a work machine, setting up a virtual ubuntu image using virtual box.

After I installed the image, I can't seem to connect to the internet.

If I look at network and sharing center on my host OS (W7) I see that the VirtualBox Host-Only Network reads as "no network access"

How can I set it up so that it uses the same network as the host OS.

UPDATE!
Okay, is there a way I can tell virtual box host-only network to use a proxy script?

share|improve this question
    
What Virtualbox version? –  grs Oct 5 '12 at 18:20

4 Answers 4

In Network Settings in VirtualBox choose Bridged Adapter and your physical adapter. I usually use Intel PRO/1000 MT Server Adapter Type, tend to work in most environments.

share|improve this answer
1  
I have the settings matching another virtual image that has no problem connecting to the internet. –  Frantumn Oct 5 '12 at 13:22

First you need to go into the virtualbox network settings and make sure it's set to something compatible with your connection, then test from within the VM.

share|improve this answer
    
I just saw something on my host network settings that says "Internet connection sharing has been disabled by the network administrator." Would this mean I simply can't do it? –  Frantumn Oct 5 '12 at 13:17

There is a complete guide to solve your problem with a proper understanding, which i have written on my blog http://vipullinux.wordpress.com/2013/06/26/networking-in-virtualbox/

share|improve this answer
up vote 0 down vote accepted

There was a type error in the proxy URL I was given by a co-worker. It is working now. Thanks for help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.