Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 Ultimate edition and the latest versions of Virtual PC and Windows XP Mode available here.

Every time I attempt to start Windows XP Mode, the setup starts, I accept the licence agreement, leave the installation folder as default, enter my password, select either of the two protection options, then click start setup. All this does is create a vmcx file called Windows XP Mode 1 in C:\Users\My Username\Virtual Machines.

This VM does nothing and its machine status stays as Powered down.

I've tried creating a new virtual machine, but the behaviour repeats and the machine never powers up.

I've tried uninstalling and reinstalling Virtual PC from the Windows updates, as well as doing the same for the Windows XP Mode install. I am a full Administration on the machine and UAC is off.

Does anyone have any idea why I cannot launch any virtual machines?

EDIT: Also, I have hardware virtualization and it's turned on.

share|improve this question
    
Has it worked in the past? Or have you tried any other virtualization software's? And what's the hardware you're using? –  Ivo Flipse Sep 29 '09 at 9:32
    
The VMs all used to work until I upgraded to Windows 7 from Vista and installed the new version of Virtual PC. It's a Toshiba Tecra A10-112. –  GenericTypeTea Sep 29 '09 at 9:35
add comment

7 Answers

up vote 2 down vote accepted
+50

According to this Virtual PC Guy's Blog:

It seems that people are constantly running into problems running Virtual PC on laptop systems with advanced power management. The reason for this is that Virtual PC is very demanding on hardware and has very strict timing requirements - and as each new revision of laptops comes along these systems perform more and more complex power management.

Problems start happening when these laptops tweak with things that we rely on. This can either be caused when the laptop changes the CPU frequency too often, or when the laptop actually powers down sections of the system that we are dependant on in order to conserve power. When this happens the user can see a variety of problems; ranging from sporadic pauses and bursts, virtual machines running too fast or too slow, repeated keystrokes or missing keystrokes to other timing related problems.

While I don't suggest following the suggestions in this article, the explanation might hold true.

The single biggest eater of CPU resources is probably Aero. You may test turning Aero off to lower the power demands, and seeing if the problem disappears.

In case it does, you may set Aero to turn off automatically when and only when VPC is run, by right-clicking its executable, choosing Properties / Compatibility and checking “Disable desktop composition”.

share|improve this answer
add comment

there was a new release today. It may be worth installing the final version.

share|improve this answer
    
No, that didn't help –  GenericTypeTea Nov 13 '09 at 11:28
add comment

Can this be a problem of compatibility with Windows Virtual PC?

Under Windows 7, XP mode is supported via Windows Virtual PC.
If you have installed "Virtual PC 2007" on your computer, then this article seems to show that there are problems when Windows Virtual PC is also installed on the same machine.

What's more, the virtual machine formats of both VPC versions are somewhat different, so a VM created with the one can't be used as-is on the other, per this article.

share|improve this answer
add comment

Re: Hardware virtualization. I know you have it and it is turned on, but I ran into a problem similar to this, also with hardware virtualization turned on. Neither Virtual PC nor VirtualBox would accept that it was available and turned on (VirtualBox would still run without it; Virtual PC would not).

The problem started when I migrated from the RC of Virtual PC to the RTM version (this was on a RTM version of 7). I could not get Windows to accept the functionality and properly report it to other applications. In the end the only solution was a system reinstall.

share|improve this answer
add comment

why not install from a copy of xp. windows 7 VPC has an option to add a ISO image to the virtual pc.go to the Virtual machines window and click on the virtual machine you have set up and go to settings. then go to DVD drive and either pick Open from an ISO image or Access a Physical drive. This will automaticly install which ever version of xp you want.here another would to download VMWARE which is free

share|improve this answer
add comment

Take in to consideration that Virtual PC and Windows Virtual PC are two different products. Do you have Virtual PC and trying to run XP mode under that? I believe that that won’t work.

share|improve this answer
    
is it a VHD ext.? –  IT_07 Nov 23 '09 at 7:35
add comment

I just tried the same, mine is W7 Ultimate, XPmode works fine. The installation starts, but it stops after the 2nd prompt with some kind of graphic error. On the Windows Virtual PC it shows as powered down.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.