Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to analyze the up-link Wireless traffic generated by my Sony Ericsson phone and captured by my D-Link router, on which I installed the DD-WRT firmware. To do this, first I log in the router and enable the prism0 interface by typing the command:

wl -i eth1 monitor 1

and then I start to capture the packets by typing:

tcpdump -i prism0 ether src xx:xx:xx:xx:xx:xx -s0 -w /tmp/smbshare/sony_ericsson_test.pcap

where xx:xx:xx:xx:xx:xx is the MAC address of my Sony Ericsson phone. After a while I transfer the sony_ericsson_test.pcap file to my computer and open it with Wireshark program. In order to display the RSSI values I follow this procedure: Edit -> Preferences... -> Columns -> Press "Add" button -> As "Field type" I choose "IEEE 802.11 RSSI" and finally I choose name "Power" and click on "Apply" button. The problem is that the column "Power" is empty with no RSSI values.

Does Anyone has a clue on why are RSSI values not displayed? Maybe I am missing a passage.

Looking forward to hearing from anyone of you!

Thanks in advance for your help!

share|improve this question

migrated from Oct 5 '12 at 16:59

This question came from our site for professional and enthusiast programmers.

Same problem, and same answer, as - apparently, the Prism headers supplied by the driver for whatever Wi-Fi adapter's on your D-Link router use different codes for the various radio information values than are used by some other drivers, and Wireshark currently supports only the codes for the other drivers and needs to be updated to support both.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.