Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have this problem that when I boot Knoppix on my Windows box, it screws up the internet connection somehow, so Windows cannot get an IP when I reboot back to XP. I use Verizon FIOS. Normally I have to fix this by calling Verizon and having them reset the network interface.

I assume that Knoppix is doing something wierd with ARP or something, I don't know, I am not a network engineer.

I have read some random stuff on the internets that things like this can get caused by the OS giving out a fake Mac address or that there is some other mac-address-related conflict going on.

Anybody know what could be wrong and how to fix it?

share|improve this question

migrated from stackoverflow.com Oct 5 '12 at 21:42

This question came from our site for professional and enthusiast programmers.

    
Complete guess, hence the commit. But it may be that the machine is grabbing an address from DHCP and that conflicts when you go back into windows, and it is trying to use an old address. If you release and renew with ipconfig it may fix it. –  grieve Oct 5 '12 at 20:28
    
No, no. No release/renew fixes it. This is way more hardcore problem than doing some simple reset. I mean you can go unplugging everything, turning everything off, releasing, renewing, turning auto this on and off, nothing fixes it. It's like it gets hardwired to some IP on the Knoppix and won't change. Not only that, but if you turn off DHCP and hard code the Knoppix IP (which works in that environment) in the Windows TCP advanced settings, it still doesn't work. I think it is because Knoppix changes the mac address and then FIOS refuses to talk to the XP mac address. –  Tyler Durden Oct 5 '12 at 20:32
    
That is a mystery. This may be a better question for ServerFault though. –  grieve Oct 5 '12 at 20:34
    
serverfault.com –  grieve Oct 5 '12 at 20:35
    
Just to clarify, when you try to renew you get an error (I forgot exactly what it was) but it amounts to an error saying that Windows is unable to located the DHCP server, even though auto detect is on. Because of this I assume ARP is not working, but I have to admit I am fuzzy on the details of how a Windows box goes about getting its IP address. –  Tyler Durden Oct 5 '12 at 21:18
show 2 more comments

1 Answer

This is very likely NOT a knoppix problem, I run knoppix all the time and it does not do any MAC-spoofing. It sounds as though your IP is staticly configured in windows. You should maybe try connecting to the router from windows with the SAME IP that knoppix gave you. You can get that ip by typing

  ifconfig

in the KNOPPIX terminal. This is most likely a windows problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.