Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to create an Alias directive with Apache 2.2, to point to a shared folder on other computer.

Apache is running on machine M1 at IP 192.168.0.103, the other machine M2, with the shared folder, is at IP 192.168.0.101.

Now I am testing M1 with Linux Ubuntu 12 and M2 with Windows 7. I am editing httpd.conf on M1. There are two Alias directives:

Alias /m1test/ "/home/test/"
Alias /m2test/ "file://192.168.0.101/test/"  

Testing:

  • http://localhost/m1test/foo.txt - is OK!
  • http://localhost/m2test/foo.txt - doesn't work

How can I make the second alias work?

share|improve this question

migrated from stackoverflow.com Oct 5 '12 at 22:27

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer

up vote 0 down vote accepted

Use the UNC path instead of the network drive letter notation (which is pretty idiosyncratic to windows).

Alias /edrive //unc/path_here/

Apache knows nothing about 'drive letters'.

BTW... to find the unc path for a networked drive, run in the windows command terminal:

  C:\> net use

It should list your drives and their unc's

share|improve this answer
    
Since i am using virtual box with win2008 my net use stands like this :\\vboxsrv\E_DRIVE. I made my alias like this : Alias /MaliasE/ "\\vboxsrv\E_DRIVE\teste/" (where teste folder is fully shared. when using google chrome: localhost/MaliasE/ i get 404 not found What should i do next ? TY –  jose mey Oct 5 '12 at 19:04
    
Just changed as u said using foreward slash / instead of backslash \ and it worked –  jose mey Oct 5 '12 at 19:37
    
@josemey great! Glad it worked out for you. Any chance you'll switch to linux or mac ;) Please mark the answer correct and up vote it if it solved your issue. –  Ray Oct 5 '12 at 19:48
    
Now we are using Ubuntu 12.04. –  jose mey Oct 10 '12 at 21:40
    
Just to get a feedback on this. I used the UNC path but also needed to mount drivers between win and linux to share the directory also using samba. After all done, it worked out! –  jose mey Oct 19 '12 at 15:49
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.