Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I like the highlighting feature in notepad++, but when using certain themes that default purple and yellow make the text unreadable, and it seems I cannot change it through style configurator. Does anyone know where I would find the option to change these? It's making working with dark themes hard.

running ANSI on XP

actually I was able to change the colors through Style configurator I used tags match highlight and tags atribute

share|improve this question

migrated from stackoverflow.com Oct 5 '12 at 22:35

This question came from our site for professional and enthusiast programmers.

2  
Voted to move to superuser. –  Asaph Nov 12 '09 at 3:25
    
I think this was addressed in a newer version of notpad –  Daniel Sep 20 '12 at 23:59
add comment

3 Answers

up vote 7 down vote accepted

For starter, have you tried 'Settings' > 'Style Configuration' and in pop up, find 'Select theme' drop down box. Choose a theme color that suits you. For example, I'm on 'Deep Black'.

share|improve this answer
1  
I like the choco, but need to make the highlights work. would be nice to overwrite the transparency on those. –  Daniel Nov 12 '09 at 3:33
2  
Go to 'Style Configurator' pop up, in your selected theme (ie/ Choco), in language choose 'Global Styles' then in style choose 'Selected text color'. Here you can change the 'Background color' value to one that suits you. –  user16823 Nov 12 '09 at 4:04
add comment

At least in notepad++ v6.2.2, some themes, such as Twilight, seem to ignore changes to the "Tag match highlight" and "Tag attribute". Meaning you end up with very hard to read highlight colors on a dark background.

It seems to be some error in the XML file for the theme. If you remove, for example, the "edgeColour" entry (which is set to styleID="0") then Notepad++ appears to parse the later entries properly - so the color changes do take effect.

share|improve this answer
    
Weird. I commented out the entire Edge colour line and it fixed my highlight issues. –  Kit Menke Feb 12 '13 at 16:19
add comment

I needed this too. As the original poster has noted, you can do this through:

Settings > Style Configurator > Global Styles ...

  • Tags match highlight
  • Tags attribute
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.